Jump to content






Photo

Xi3 Xi5A ramblings

Posted by pete_c , 21 June 2016 · 716 views

Purchased two Xi3 Xi5A (AKA Piston / Steam) micro PC's last week. The company has gone out of business.

They are well built machines. They were introduced in 2013 at CES.
 
Piston Wiki Steam Machine (hardware platform)
 
Posted Image
 
Here is an early review of the device from 2012
 
The Xi3 PC: what you need to know

They were also expensive at between $500+ USD each. Purchased each here for $60 USD.
 
 
Xi3 Xi5A 1



I am doing a comparison here to the PiPoX7. The PipoX7 is an Atom Baytrail with 2Gb of RAM. Mine is currently running Windows 10.

Goals here are to make one a mini Homeseer automation server replacing the current RPi2/3 and the other one a KodiBuntu box (just to see how it works mostly).
 
Drivers
 
Take apart pictures.

Specifications of the Xi3 Xi5A.
 
Testing OS's

I - the Xi5A came with 64 bit Windows 7 Pro - runs fine - wiped it after playing. I could have removed / replaced the SSD drive but did not.
A - worked fine out of the box

II - Installed KodiBuntu on it and had to redo the AMD video / audio drivers on it - sort of a PITA but easy.
A - worked fine except for the video / HD audio issues until I updated the drivers.

III- Stock Xi5A came with OpenSuse such that I downloaded the ISO and giving that a try today.

A - Well looked nice out of the box.
B - Updated it and broke the build. I haven't played with OpenSuse in some 20 years such that I am not versed in it today.

IV - Doing a fresh install of LUbuntu on it then installing KODI.
A - Installed LUbuntu V.16.04. So far it is looking nice.  See's all hardware just fine.
B - installed openssh-server
C - installed webmin
Xi5A Webmin

D - updated build
lshw -c video
  *-display
       description: VGA compatible controller
       product: Advanced Micro Devices, Inc. [AMD/ATI]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 5
       bus info: [email protected]<script data-cfhash='f9e31' type="text/javascript">/*  */</script>:01:05.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0
       resources: irq:18 memory:d0000000-dfffffff ioport:9000(size=256) memory:f0100000-f010ffff memory:f0000000-f00fffff

lshw -c sound
  *-multimedia
       description: Audio device
       product: RS780 HDMI Audio [Radeon (HD) 3000 Series]
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 5.1
       bus info: [email protected]/*  */:01:05.1
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list
       configuration: driver=snd_hda_intel latency=0
       resources: irq:19 memory:f0110000-f0113fff
  *-multimedia
       description: Audio device
       product: SBx00 Azalia (Intel HDA)
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 14.2
       bus info: [email protected]/*  */:00:14.2
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: driver=snd_hda_intel latency=64
       resources: irq:16 memory:f0500000-f0503fff

E - will be updating BIOS as it is from 2012 to a newer one from 2014.

F - changed root password and configured SSH to work with root

V - installed Kodi
sudo apt-get install software-properties-common
sudo add-apt-repository ppa:team-xbmc/ppa
sudo apt-get update
sudo apt-get install kodi
 
A - tested HD video and audio - working fine in KODI
 
VI - started from scratch with the current KodiBuntu ISO.
 
A - Video worked fine from scratch
B - Audio didn't work until I installed PulseAudio - working fine.
C - new add considerations
1 - larger SSD
2 - HDMI cable to video port.

VII - took apart the Xi5A last night.  Easy except for the hex sockets.
 
A - imaged the SSD to a USB stick
B - shrunk the image down to around 4Gb (from 32 Gb)
C - installed another SSD drive (32 Gb) in the Xi5A, wiped it clean before installing.
D - Wrote the shrunken image from the USB stick to the SSD with Gparted
E - checked grub and did a quickie repair of the SSD with Boot-Repair (just in case)
F - Booted up fine in to KodiBuntu.  Was a bit concerned that maybe the UUID would change and it didn't.
G - will take some pictures today as there isn't much to the Xi5A.  Noticed too while sitting idle it is very cool.
H - Upping the SSD drive on one of them.
I - Noticed there is no optical audio port. I did assume that one was an optical one.  It is not labeled as such though.
 
X3S X5A 1

X3S X5A 2

X3S X5A 3

 
30th of June, 2016 status
 
- migrated Homeseer 3 lite from the RPi2 in the attic to the Xi5A.  The RPi2 has a GPIO Zwave + card.  I am using the Z-Wave controller with a direct IP connect to the Xi5A.  I had added a small 1-wire network to the RPi2 in the attic and sending that info over to the Xi5A - All is running well with it.
- second Xi5A is a Kodi box.  Left it on for the last few days and working well.  Might use it instead as a Davis Vantage Pro Cumulus MX box (remote site). 
 




Photo
philipmasterson015
Sep 23 2016 12:33 AM

Thanks for sharing this information. It's a great help.

  • Report

January 2017

S M T W T F S
1234567
891011121314
15161718192021
2223 24 25262728
293031    

Recent Comments