Jump to content






Photo

Troubleshooting my USBUIRT that wont listen.

Posted by Shinyshoes , 09 December 2010 · 712 views

Computers
Since my last post, I have got all my Virtual servers back up and running and all the drivers installed.  For the first time since I upgraded to Server 2008 in August I have finally got HD video on my Living room TV and 5.1 audio on the ceiling speekers from my computer downstairs in the utility room.

I re-installed my Premise virtual machine and my "Development" Premise Virtual Machine.  I got all the settings back tot he way they were and I could finally start making progress again.  I wanted to start with my USBUIRT so I could start to control some of my IR components.  

I plugged the USBUIRT into my server and got it passed to the Premise machine with the USB over IP software.  Once it was passed through, I installed the driver on the Premise (Windows XP) machine.  Then I installed the USBIRUT Premise driver found in the cocoontech forums.  Once everything was added, I tried to connect and instantly the version number and such was coming up in Premise, so I was connected.  I was starting to add IR Commands from the remotes to Premise Objects but the UIRT didn't seem to be receiveing commands.  hmmmm.....

I tried manually entering an IR command into my object and then sending the Command to the TV.  The TV responded to the commands, so the URIT would at least send commands properly.

I played around with the settings in Premsie but couldnt get it to go.  I then re-formatted, Re-installed everything and tried again to see if it would fix it.  Nothing.  At the suggestion of somebody on the forums, I downloaded a program that was written for the UIRT.  Using that program the UIRT works for both sending and receiving flawlessly.

Next I tried using my Development Premise virtual machine.  I redirected the UIRT to the Development machine using the USB over IP software and installed the drivers, but still no go.

I have a couple more ideas to try over the next few days.  

1) I have another USBUIRT coming, so I can see if I have a flakey device.
2) Install a NON-Virtual XP environment on another computer I have laying around to see if the Virtualization or the USB over IP is causing the problem.

If neither of those work, I am stuck.  May have to look at a GC-100 i guess.......




Photo
Dan (electron)
Dec 10 2010 11:01 AM
You don't have any other machines on your network where you can try the receiver? USB/Serial over IP software can create some weird issues, so that would be my first guess as well. I guess your Host doesn't support passing USB through like ESXi?
  • Report
I do have other machines on the network, but 1 of them is using windows 7 (which premise doesn't like) an the other 1 is my wifes and messing with that one is a death wish. It wont take long for me to build another XP machine with the plethora of computers I have laying around. Besides, if the USB over IP software is to blame, I will need the other machine to run Premise on permenantly.....
  • Report
Have you checked out the Global Cache IP based products? The GC-100 line and the iTach line both work with Premise and do their job very well. In fact, I got Global Cache to fix an issue with their iTach firmware and it now works flawlessly with Premise. I'm using the WiFi 2 IR for a tv, xbox, and receiver in lieu of running wire cat5. I know the global cache stuff is a little more money, but it's much simpler to use wifi or ethernet and just let Premise talk to it over the network.

Since you are using a virtual machine, do you think that could be the issue? I highly doubt all USB drivers will work with an XP VM, but I could be wrong.

I'm sure you've tried this but, I would try grabbing an old laptop, install Premise and see if the UIRT module works. I don't use Premise with VM, but use it on a dedicated mini-ITX PC in a 42" leviton structured wiring box. I then remote desktop in if I need to reboot the PC, but usually I just use Premise Builder from any PC to make changes.
  • Report

January 2021

S M T W T F S
     12
3456789
10111213141516
171819202122 23
24252627282930
31      

Recent Comments

Latest Visitors

  • Photo
    willmo
    30 Nov 2019 - 17:04
  • Photo
    garyg2
    03 Oct 2019 - 19:37
  • Photo
    bighorn
    31 Jan 2019 - 00:02
  • Photo
    Donut
    21 Jan 2019 - 23:54
  • Photo
    Edge540
    14 Sep 2018 - 20:36
  • Photo
    MStan
    01 Sep 2018 - 10:45
  • Photo
    jeffdoo
    18 Jun 2018 - 20:39
  • Photo
    jrfuda
    15 Dec 2017 - 11:51
  • Photo
    Stanley
    11 Dec 2017 - 06:11
  • Photo
    cavnet58
    29 Oct 2017 - 15:36
  • Photo
    eidde
    01 Feb 2017 - 19:01
  • Photo
    apalrd
    23 Oct 2016 - 10:46
  • Photo
    smmaxxx
    12 Sep 2016 - 06:26
  • Photo
    Hobby_Boy
    10 Aug 2016 - 11:36
  • Photo
    Bzncrewjr
    05 Apr 2016 - 20:44
  • Photo
    webmtn
    10 Mar 2016 - 12:48
  • Photo
    WCG
    14 Feb 2016 - 18:39
  • Photo
    kaveman
    01 Feb 2016 - 20:27
  • Photo
    securitybill
    26 Jan 2016 - 08:07
  • Photo
    Phantom20
    23 Jan 2016 - 12:25