Jump to content






Photo

Roadblocks everywhere

Posted by Shinyshoes , 19 January 2011 · 1115 views

Grrrr!

The last 2 weeks have been very frustrating.  I am still having trouble getting my USBUIRT working on a virtual Premise server.  I tried 3 different software USB over IP solutions to try to get the UIRT passed through to the virtual machine and none of them will work properly.  So now I have split my attention into 3 different possible solutions.  

1. Purchase a hardware USB over network box such as Digi's AnywhereUSB
2. Get another Computer up and running with ESXi server and use the USB passthrough built in
3. Get another Computer up and running with Windows XP and forget about using a virtual environment for Premise.

well, 1 - the $$$$ of a AnywhereUSB is a little intimidating considering there is no guarantee that the $100-150 to buy one is going to solve my problem.  What if it has the same results as the software packages?  I'm keeping an eye open on Ebay for a good price but who knows how long that could take.......

2 - I started to build a computer with the spare parts I have laying around, but when I tried to install ESXi on it, it appears that it is installing properly, but then it re-boots, and the hard drive tries to boot into the windows install that was on it before.  My next attempt will be to format the drive and try again.  Not sure what is going on there.

3. I have another old machine that I installed a new copy of XP on and got Premise installed on.  My plan was to hook the USBUIRT to it directly and use my IR Repeater to send the signals from the living room down to the mechanical room where the server is.  Apparently my UIRT and my repeater dont work together.  I can point the remote directly at the UIRT and receive the signal, but if I point my remote at the repeater, I get nothing from the UIRT, but the device will react.  My next plan was to use the same USB to cat5 converter cable that I built and plug the UIRT in upstairs and have it sit under the TV.  When I try to do that, the XP machine doesn't recognize the UIRT.  The cable must be too long for the UIRT to work, despite my Wireless keyboard receiver working fine from the same USB port........

So 3 different solutions and 3 roadblocks.  Man, this is frustrating.  

The plan now is to continue to watch for a decently priced AnywhereUSB.  For the ESXi server I will try formatting the drive and re-installing it.  If that doesn't work, I will have to try re-downloading ESXi and making another disk.  

The 3rd way is the way I would prefer to go, so it is getting the bulk of my attention.  I have ordered 2 different types of active USB extension cables that I am going to run from my mechanical room to my living room.  If that works, I might try cutting the ends off (the active part of the cable) and soldering them onto the cat5 cable that I am currently trying to use.  My hope is that the amplifier or whatever it uses to boost the signal will still work over the cat5 cable. However, this next attempt is on hold till my order gets in from Monoprice.....

Other stuff I have on the Go:

I found out that My TV will only do picture in picture if one of the sources is the cable input.  Sounds silly to me considering the TV has 4 HDMI and 1 component input......  I bought a cheep RF converter and plugged it into zone 2 of my amplifier and hooked output of that into my TV.  I also hooked up another (standard Def) Satellite receiver so now I can get picture in picture on my TV with any source on my receiver.  Well, almost any source.  Durring this process, I found out that my receiver will down-convert a component or S-video signal to Composite on the "monitor" port for the main zone, but wont for the zone 2 output.  This means all my component and s-video sources (HD Satellite reciever, Xbox 360, Wii, Server 2008 Box, Windows XP Premise box) wont be visible on the picture in picture.  Oh well.  At least I can watch 2 hockey games at once.

I had a hard drive failure on my Server on friday.  I lost the OS drive which also took down all my virtual servers.  I got everything up and running again in about 36 hours, and finally got all the drivers and virus scan and everything back to the way it was last night (4 days later).  I am getting pretty good at re-building that server, as this is the 4th time I had to do it.  You would think that by now I would have taken a good backup of the install so I can just re-image it.  Nope.  Hopefully I can do that tonight.

For Christmas I bought my wife a Driveway sensor.  She had been complaining about how we have no sight line from our kitchen/living room area to the driveway.  Being on an Acreage, It would be really nice to know when somebody is poking around.  The system I bought has a wireless transmitter box that mounts on a fencepost and a sensor that gets burried under our road.  When the sensor is tripped (magnetically) the transmitter sends a signal to a receiver in the house that makes a sound.  The receiver also has contacts on the back of it that close when the sensor is tripped, which makes it easy to tie into the home automation box.  That will work perfectly with the Axis security camera I just bought to mount on that side of the house so when the driveway sensor gets tripped, the security camera picture will come up on the "picture in picture" of the TV.  Thats the plan anyhow......

Finally, I bought a Nuvo Concerto on Ebay just before Christmas.  My brother had some left over Grand Concerto and Grand Essentia display pads that I bought off him.  I then ordered the Nuvo Grand Concerto MCU board to upgrade the Conerto to a grand concerto.  The MCU board should be here before the end of the month.

Thats the bulk of what I have going on.  Hopefully my server wont crash again and I can actually get some stuff done.  Knock on wood.




Sorry to hear about all the problems. Hopefully you get some solutions shortly.
  • Report
I did solve 1 thing. I realized the ESXi 4.1 I was trying to install is 64 bit only. The hardware I scrounged up is only 32 bit. A co-worker has offered to sell me a motherboard/CPU/Ram that is 64 bit. Once I get that I will continue down the ESXi route.
  • Report
Sorry about to hear of your issues. I've tested to work:

1 - Digi Anywhere USB with my Homeseer setup and the following configuration on a W2003 box.
Digi Anywhere box to 2 Digi 8 port Edgeports. All of the 16 serial devices worked fine. The W2C and USB sound device kind of worked but not really well. I then tested the two devices with the Lantronix USB to LAN box and it did work. Concurrently I've only tested the first above mentioned setup in a VM except for the USB Sound/W2C box and validated it functionality just fine.
2 - Quatech 4 port serial to Network boxes have been validated and work fine.

I am not doing any IR though. I've also tested a couple of pure software USB to networking solutions and they do work but not as well as the Digi / Lantronix stuff.

I am not using ESXi server but rather just testing with VMWare workstation. Its just set up on my desktop to play with. I have a few Linux servers, W2003, W7,and XP configurations set up. I do have issues when I "move" from real to virtual on the USB devices relating to devices that stick to one configuration or another. The easiest setup though is when I use one USB port to USB hub to 16 serial ports. I have a configuration on my HS devices which I have documented relating to what device talks to what serial port relating to individual com port numbers. Another device that didn't work with a virtual USB port was the SA USB PIM. The USB serial PIM worked fine. I called SA and they told me that specific USB drivers would have to be written for the virtual piece.
  • Report
Testing all 32bit. Testing 64bit was a bit more work with both directory structure (where is what) and drivers for me...did read though to configure "stuff" in the root of the 64bit machine to make it easier to flip going from 32bit to 64bit and vice versa.
  • Report

February 2019

S M T W T F S
     12
3456789
10111213141516
171819 20 212223
2425262728  

Recent Comments

Latest Visitors

  • Photo
    bighorn
    31 Jan 2019 - 00:02
  • Photo
    Donut
    21 Jan 2019 - 23:54
  • Photo
    Edge540
    14 Sep 2018 - 20:36
  • Photo
    MStan
    01 Sep 2018 - 10:45
  • Photo
    jeffdoo
    18 Jun 2018 - 20:39
  • Photo
    willmo
    25 Mar 2018 - 11:53
  • Photo
    jrfuda
    15 Dec 2017 - 11:51
  • Photo
    Stanley
    11 Dec 2017 - 06:11
  • Photo
    cavnet58
    29 Oct 2017 - 15:36
  • Photo
    eidde
    01 Feb 2017 - 19:01
  • Photo
    apalrd
    23 Oct 2016 - 10:46
  • Photo
    smmaxxx
    12 Sep 2016 - 06:26
  • Photo
    Hobby_Boy
    10 Aug 2016 - 11:36
  • Photo
    Bzncrewjr
    05 Apr 2016 - 20:44
  • Photo
    webmtn
    10 Mar 2016 - 12:48
  • Photo
    WCG
    14 Feb 2016 - 18:39
  • Photo
    kaveman
    01 Feb 2016 - 20:27
  • Photo
    securitybill
    26 Jan 2016 - 08:07
  • Photo
    Phantom20
    23 Jan 2016 - 12:25
  • Photo
    dementeddigital
    22 Jan 2016 - 08:52