Jump to content


Photo

eKeypad Plus - Version 1.4


  • Please log in to reply
26 replies to this topic

#1 jaysonc

jaysonc

    Dedicated Cocooner

  • Manufacturers
  • PipPipPip
  • 249 posts
  • Location:Dallas, TX
  • Experience:guru
  • Hardware:Elk M1, HAI OmniPro II, ISY-99, Mi Casa Verde Vera
  • Tech:X10-PLC, UPB, INSTEON, Z-Wave, 1-Wire, RadioRA, Control4
  • Audio:Russound
  • Video:Custom
  • CCTV:analog, ip, dvr

Posted 30 March 2009 - 10:54 AM

A new version of eKeypad Plus is available on iTunes today.

Version 1.4.0 adds:

- A completely integrated caching system
- A new status screen for configured systems.
- Bug fixes.

The new caching system greatly increases runtime performance. It is especially beneficial for people using eKeypad Plus over cellular connections with a weak signal strength. The status and the ability to manage the can be found in the new status screen.

You can read more about eKeypad Plus at the official website.

#2 clearwater

clearwater

    Cocooner

  • Registered
  • PipPip
  • 33 posts
  • Location:Canada

Posted 30 March 2009 - 12:00 PM

Great and I will update it tonight. Thanks Jason. :)

A new version of eKeypad Plus is available on iTunes today.

Version 1.4.0 adds:

- A completely integrated caching system
- A new status screen for configured systems.
- Bug fixes.

The new caching system greatly increases runtime performance. It is especially beneficial for people using eKeypad Plus over cellular connections with a weak signal strength. The status and the ability to manage the can be found in the new status screen.

You can read more about eKeypad Plus at the official website.



#3 kccustom

kccustom

    Dedicated Cocooner

  • -=Gold Supporter=-
  • 125 posts
  • Location:Kansas City, KS
  • Experience:novice
  • Software:Indigo
  • Hardware:Elk M1
  • Tech:INSTEON
  • CCTV:analog, dvr

Posted 30 March 2009 - 03:11 PM

I had to redo all of my config info, seems the update made me start from scratch. Thats a whole 45 seconds of my life that I will never get back! :)

#4 BryanE

BryanE

    Dedicated Cocooner

  • Registered
  • PipPipPip
  • 187 posts

Posted 30 March 2009 - 05:11 PM

Thanks Jason!

What whole house audio support is being added (Russound)?

#5 jaysonc

jaysonc

    Dedicated Cocooner

  • Manufacturers
  • PipPipPip
  • 249 posts
  • Location:Dallas, TX
  • Experience:guru
  • Hardware:Elk M1, HAI OmniPro II, ISY-99, Mi Casa Verde Vera
  • Tech:X10-PLC, UPB, INSTEON, Z-Wave, 1-Wire, RadioRA, Control4
  • Audio:Russound
  • Video:Custom
  • CCTV:analog, ip, dvr

Posted 30 March 2009 - 06:31 PM

Thanks Jason!

What whole house audio support is being added (Russound)?


Russsound, Nuvo and Proficient will be the first supported systems.

--
Jayson

#6 opie

opie

    Dedicated Cocooner

  • Registered
  • PipPipPip
  • 404 posts
  • Location:Colorado

Posted 31 March 2009 - 07:05 PM

Noticeable speed improvement; thanks for the update!

#7 clearwater

clearwater

    Cocooner

  • Registered
  • PipPip
  • 33 posts
  • Location:Canada

Posted 31 March 2009 - 09:04 PM

Something is wrong after I have upgraded to this new version.
I have two iphones (one for ekeypad V.1.4.0 and one for V.1.2.2) with
the same settings. For some reason, the new update ekeypad is
giving me "Querying Keypad Setup .." and took forever.
Status is showing never connected. Any idea what am I doing wrong?

#8 BryanE

BryanE

    Dedicated Cocooner

  • Registered
  • PipPipPip
  • 187 posts

Posted 31 March 2009 - 10:21 PM

Something is wrong after I have upgraded to this new version.
I have two iphones (one for ekeypad V.1.4.0 and one for V.1.2.2) with
the same settings. For some reason, the new update ekeypad is
giving me "Querying Keypad Setup .." and took forever.
Status is showing never connected. Any idea what am I doing wrong?


I had the exact same issue. I tried to uninstall and reinstall but now I get "Unable to connect to IP Address and port provided". However, nothing has changed on the Elk side. I have no problem bringing up the Elk web interface on the specified IP and Port. Additionally, after this happens I cannont re-open "Config" to change the settings... the app just crashes.

#9 jayadkins

jayadkins

    Newbie

  • Registered
  • Pip
  • 7 posts
  • Location:Columbus, OH USA

Posted 01 April 2009 - 01:12 PM

Program was working fine for me too until the latest update. Wiped my settings (no big deal), but now the program loads, queries the system for info, and crashes to home page. Hard reboot of the phone didn't help. :D

Nonetheless, I love this app. Works great for my needs and is definitely the most used application on my phone.

#10 clearwater

clearwater

    Cocooner

  • Registered
  • PipPip
  • 33 posts
  • Location:Canada

Posted 01 April 2009 - 05:40 PM

Since we got no reply from Jason, are we safe to assume that Jason is working on it?
The old version works fine and this upgraded patch is not up to the expectation.

A few of us here are reporting the same problem.
Is anyone out there has any success with this new version 1.4? :D

#11 jaysonc

jaysonc

    Dedicated Cocooner

  • Manufacturers
  • PipPipPip
  • 249 posts
  • Location:Dallas, TX
  • Experience:guru
  • Hardware:Elk M1, HAI OmniPro II, ISY-99, Mi Casa Verde Vera
  • Tech:X10-PLC, UPB, INSTEON, Z-Wave, 1-Wire, RadioRA, Control4
  • Audio:Russound
  • Video:Custom
  • CCTV:analog, ip, dvr

Posted 02 April 2009 - 12:02 AM

I am sorry you guys are having issues with the update.

The need to re-enter the configuration is a bug. eKeypad is storing part of the configuration in a location that I understood to be persisted across updates. Clearly It is not and resulting in an invalid/partial configuration. This is the cause of the crashed when entering the configuration screens.

If you go into the iPhone settings app you will find an eK Plus entry with a single toggle. This will clear all partial configuration data by reseting the configuration data.

When re-entering the configuration, please be sure your eKeypad configuration matches your XEP setup. The web site ( http://web.me.com/japps/eKeypad_Plus/ ) details the procedure. Specifically the security section contain settings that eKeypad can not verify nor identify invalid settings. Often incorrect security settings will cause eKeypad to behave as I am seeing in this thread.

If these general guides do not resolve your issues please email me and I will work with you to get you working again. I know many users sucessfully who have sucessfully upgraded, so I am sure we can resolve the isues you are seeing.

Please note that I am at ISC West this week so will only have intermittant access to the forum until Saturday. The eKeypad support email will reach me more easily.

#12 clearwater

clearwater

    Cocooner

  • Registered
  • PipPip
  • 33 posts
  • Location:Canada

Posted 02 April 2009 - 12:15 AM

Jason,
Thanks for the update. Yes. I got to the iphone app and resetting
the ekeypad plus. Now, everything appears to work now. :D

Thanks.

I am sorry you guys are having issues with the update.

The need to re-enter the configuration is a bug. eKeypad is storing part of the configuration in a location that I understood to be persisted across updates. Clearly It is not and resulting in an invalid/partial configuration. This is the cause of the crashed when entering the configuration screens.

If you go into the iPhone settings app you will find an eK Plus entry with a single toggle. This will clear all partial configuration data by reseting the configuration data.

When re-entering the configuration, please be sure your eKeypad configuration matches your XEP setup. The web site ( http://web.me.com/japps/eKeypad_Plus/ ) details the procedure. Specifically the security section contain settings that eKeypad can not verify nor identify invalid settings. Often incorrect security settings will cause eKeypad to behave as I am seeing in this thread.

If these general guides do not resolve your issues please email me and I will work with you to get you working again. I know many users sucessfully who have sucessfully upgraded, so I am sure we can resolve the isues you are seeing.

Please note that I am at ISC West this week so will only have intermittant access to the forum until Saturday. The eKeypad support email will reach me more easily.



#13 jaysonc

jaysonc

    Dedicated Cocooner

  • Manufacturers
  • PipPipPip
  • 249 posts
  • Location:Dallas, TX
  • Experience:guru
  • Hardware:Elk M1, HAI OmniPro II, ISY-99, Mi Casa Verde Vera
  • Tech:X10-PLC, UPB, INSTEON, Z-Wave, 1-Wire, RadioRA, Control4
  • Audio:Russound
  • Video:Custom
  • CCTV:analog, ip, dvr

Posted 02 April 2009 - 12:54 AM

Excellent. Now you can enjoy the much improved performance caching has enabled!
I did a lot of testing on this version, and hate the configuration issue slipped by.

I look forward to hearing from the others in the thread that are experiencing issues. I am confident a configuration reset and setup will fix their issues as well.

#14 jayadkins

jayadkins

    Newbie

  • Registered
  • Pip
  • 7 posts
  • Location:Columbus, OH USA

Posted 02 April 2009 - 10:23 PM

Jayson's recommendations fixed my issues. Works great now. Nice and speedy!

Dude, you have a great app here. I wish you all the best. Make lots of money :P

#15 jaysonc

jaysonc

    Dedicated Cocooner

  • Manufacturers
  • PipPipPip
  • 249 posts
  • Location:Dallas, TX
  • Experience:guru
  • Hardware:Elk M1, HAI OmniPro II, ISY-99, Mi Casa Verde Vera
  • Tech:X10-PLC, UPB, INSTEON, Z-Wave, 1-Wire, RadioRA, Control4
  • Audio:Russound
  • Video:Custom
  • CCTV:analog, ip, dvr

Posted 03 April 2009 - 12:08 AM

Thanks for the update. I try very hard to completely test eKeypad releases, but occasionally bugs get through. At least now this type of issue can be safeguarded against. I have already made changes to handle this scenario more gracefully in the future and minimize the posibility of it re-occuring.

I also would like to encourage all users to post their experiences with eKeypad in the iTunes. This will allow everyone to share your experience.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users