Jump to content


Photo
- - - - -

Lastest firmware download for WC8 and WC32


  • Please log in to reply
76 replies to this topic

#1 CAI_Support

CAI_Support

    Cocoonut

  • Manufacturers
  • PipPipPipPip
  • 2271 posts
  • Location:California

Posted 29 November 2015 - 12:02 PM

If your board having older firmware, you can download these latest firmware and update your board.

 

For wc32 board only, download from this link:
http://www.cainetworks.com/support/download/wc32update040211.zip

For wc8  hardware rev 2.2.2 board, please update with this firmware
http://www.cainetworks.com/support/download/wc8plc030224-update.zip

For wc8 hardware rev 2.3.x board, this is the new version:
http://www.cainetworks.com/support/download/wc8plc030321-update.zip

 

These will be the official releases for WC8 and WC32 boards.



#2 CAI_Support

CAI_Support

    Cocoonut

  • Manufacturers
  • PipPipPipPip
  • 2271 posts
  • Location:California

Posted 14 December 2015 - 02:13 PM

We have made slight change to 1-wire temp sensor reading timing, so that default TDSO == 3uS can be adjusted to wider range. This will help some temp sensor reading failure issue.

For wc8  hardware rev 2.2.2 board, please update with this firmware
http://www.cainetworks.com/support/download/wc8plc030225-update.zip

 

 

For wc8 hardware rev 2.3.x board, this is the new version:
http://www.cainetworks.com/support/download/wc8plc030322-update.zip

As always, any feedback and suggestion is welcome.


Edited by CAI_Support, 14 December 2015 - 07:21 PM.


#3 CAI_Support

CAI_Support

    Cocoonut

  • Manufacturers
  • PipPipPipPip
  • 2271 posts
  • Location:California

Posted 19 December 2015 - 01:28 PM

We made slight email queue logic change to make sure sending sequence is exactly as PLC called.  It also further adjusted 1-wire timing for temp sensors.

For wc8  hardware rev 2.2.2 board, please update with this firmware
http://www.cainetworks.com/support/download/wc8plc030226-update.zip

For wc8 hardware rev 2.3.x board, this is the new version:
http://www.cainetworks.com/support/download/wc8plc030323-update.zip

 

Please let us know your feedback and suggestions. Happy Holidays!


Edited by CAI_Support, 19 December 2015 - 03:22 PM.


#4 CAI_Support

CAI_Support

    Cocoonut

  • Manufacturers
  • PipPipPipPip
  • 2271 posts
  • Location:California

Posted 04 January 2016 - 11:39 AM

We do recommend for all WC8 hw rev 2.3.8 customers to update the firmware to this latest 3.03.23 level for improved 1-wire sensor communication.



#5 BTCAD

BTCAD

    Dedicated Cocooner

  • Registered
  • PipPipPip
  • 261 posts
  • Location:Canada, Ontario
  • Experience:novice
  • Software:Open Source Automation, Custom
  • Audio:Custom
  • CCTV:ip
  • Phone:magicJack

Posted 17 January 2016 - 09:55 AM

What new with w32 new firmware?   New features?



#6 CAI_Support

CAI_Support

    Cocoonut

  • Manufacturers
  • PipPipPipPip
  • 2271 posts
  • Location:California

Posted 18 January 2016 - 11:48 AM

@BTCAD,

 

The above WC32 is a bug fix release, that fixed two bugs,

1) sometimes PLC reads the string table from wrong location.

2) sometimes PLC got wrong temperature sensor.

 

4.02.11 fixed all known bugs.  User should update to the latest firmware, if possible.



#7 CAI_Support

CAI_Support

    Cocoonut

  • Manufacturers
  • PipPipPipPip
  • 2271 posts
  • Location:California

Posted 18 January 2016 - 11:55 AM

We are working on update WC8 firmware to have temperature sensor parasite support.  It is working in our lab. We need to have it pass temperature chamber 70C testing before release.  it could be in next few days.  All current WC8 users with hw rev 2.2.2 and 2.3.x  will be able to update to new firmware and get the improvement feature.



#8 CAI_Support

CAI_Support

    Cocoonut

  • Manufacturers
  • PipPipPipPip
  • 2271 posts
  • Location:California

Posted 18 January 2016 - 06:28 PM

New firmware updates are available for download.  This update allows temp sensors operating in parasite mode, also with improved high temperature handling.

 

For wc8  hardware rev 2.2.2 board, please update with this firmware
http://www.cainetworks.com/support/download/wc8plc030227-update.zip

For wc8 hardware rev 2.3.x board, this is the new version:
http://www.cainetworks.com/support/download/wc8plc030324-update.zip

 

Please provide your feedback and suggestion, we highly appreciate it.



#9 ja02333

ja02333

    Cocooner

  • Registered
  • PipPip
  • 11 posts

Posted 18 January 2016 - 09:12 PM

Tried new firmware and none of the sensors are working.

Replaced with old 30323 firmware and read temperature from the sensors



#10 CAI_Support

CAI_Support

    Cocoonut

  • Manufacturers
  • PipPipPipPip
  • 2271 posts
  • Location:California

Posted 18 January 2016 - 10:18 PM

That is strange, since we tested with 8 sensors on a 100ft cable, with board cooked in temperature chamber from room to 70C.

I will report this to development to see what is the problem--- the download image problem or anything else.



#11 CAI_Support

CAI_Support

    Cocoonut

  • Manufacturers
  • PipPipPipPip
  • 2271 posts
  • Location:California

Posted 18 January 2016 - 10:45 PM

I just downloaded from the site by clicking on the 2nd link, updated one board and it working.  I will try another board and report.

 

Just tested with a stock board and updated to this firmware, it works fine.  @ja02333: Could you please take a look under your general tab, TDSO value, what was it?  Please make sure set that between 3 to 5 first.


Edited by CAI_Support, 18 January 2016 - 11:52 PM.


#12 ja02333

ja02333

    Cocooner

  • Registered
  • PipPip
  • 11 posts

Posted 19 January 2016 - 05:04 AM

Tried the download from the site, installed firmware, still do not see the 6 sensors, all sensors are on short cables around 3 ft.

Board settings tried 3 and 5.

All sensors show all zeros and no sensors are shown during the selection settings.

v03.03.24

removed all but 1 sensor and still do not see it.

If I go back to the v.03.03.23 it works.



#13 CAI_Support

CAI_Support

    Cocoonut

  • Manufacturers
  • PipPipPipPip
  • 2271 posts
  • Location:California

Posted 19 January 2016 - 12:02 PM

@ja02333

what part number on your sensor?  We tested with DS18B20, DS1822-PAR, and DS18S20.  During testing one DS18B20 is directly on the board in the temperature chamber, remaining 7 are on a cable in 7 segments, the longest distance is 100ft.

 

Do you have another board to test?  Could you please try to change TDSO value from 1 to 7, after change the value, you will need to restart the board, so that board rescan the 1-wire bus.



#14 ja02333

ja02333

    Cocooner

  • Registered
  • PipPip
  • 11 posts

Posted 19 January 2016 - 12:30 PM

Thanks for you assistance.

I purchased the sensors from Amazon  (Vktech DS18B20)

I only have one board.

If there are no major improvements with the new release I can use the v03.03.23 version for now.



#15 BTCAD

BTCAD

    Dedicated Cocooner

  • Registered
  • PipPipPip
  • 261 posts
  • Location:Canada, Ontario
  • Experience:novice
  • Software:Open Source Automation, Custom
  • Audio:Custom
  • CCTV:ip
  • Phone:magicJack

Posted 19 January 2016 - 12:36 PM

I found a bug in 4.02.11  (wc32)

 

The board cannot handle the right time.  I was running for a long time with 4.02.08A without any problem, I updated the new firmware  but the time wasnt handle correctly. I tried to reboot the board, times and date has been fixed but after 2 minutes, i got : 04/09/2092    09:21:00 again...   Tried to flash again the firmware but nothing changed. I uploaded 04.02.08A then time bug fixed. I tried 2 different board.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users