Jump to content


Photo
- - - - -

Can't turn Chime off properly with Rules


  • Please log in to reply
4 replies to this topic

#1 steerage250

steerage250

    Cocooner

  • Registered
  • PipPip
  • 21 posts
  • Experience:novice
  • Hardware:Elk M1
  • Phone:VoIP via ISP

Posted 20 August 2017 - 10:45 PM

I have some rules that set Chime on and off.  The rule to turn it on works fine (and the Chime soft-button on my keypad is illuminated), but the rule to turn it off doesn't work so well.

 

The system voice-announces "Chime is off" and the Chime soft-button on the keypad is no longer lit, but the zones still chime.  If I then press the Chime button on the keypad, it says "Chime is off, and the zones don't chime anymore.

 

You can see in the attachment that I have repeated the instruction to turn chimes off, but that didn't help and just resulted in 2 "Chime is off" announcements.

 

Anyone got any ideas ?

Attached Files



#2 DELInstallations

DELInstallations

    Cocoonut

  • Professionals
  • PipPipPipPip
  • 5400 posts
  • Software:Custom
  • Hardware:Custom
  • Tech:ZigBee
  • Audio:Custom
  • Video:Custom
  • CCTV:analog, ip, dvr

Posted 21 August 2017 - 09:15 PM

How is the flag/phantom output being triggered? Curious if you've tried the reverse action, chime manually on and rule turn off, if that changes state


Edited by DELInstallations, 21 August 2017 - 09:16 PM.


#3 Work2Play

Work2Play

    Cocoonut

  • -=Gold Supporter=-
  • 4877 posts
  • Location:Northern California
  • Experience:guru
  • Software:Elve
  • Hardware:Elk M1, RUC-01
  • Tech:X10-RF, UPB
  • Audio:AirPlay
  • Video:XBMC
  • CCTV:ip, dvr
  • Phone:3CX, Asterisk, FreePBX, Grandstream, Ooma

Posted 23 August 2017 - 02:30 PM

sometimes it's as easy as reversing the order of the rules - but it sounds like you're getting some sort of double-firing of rules.



#4 steerage250

steerage250

    Cocooner

  • Registered
  • PipPip
  • 21 posts
  • Experience:novice
  • Hardware:Elk M1
  • Phone:VoIP via ISP

Posted 09 October 2017 - 08:06 AM

oops, i've only just realised i need to follow a topic (even if i started it) to get email notification of responses.  I will have more of a look and respond.

 

thanks for your ressponses



#5 steerage250

steerage250

    Cocooner

  • Registered
  • PipPip
  • 21 posts
  • Experience:novice
  • Hardware:Elk M1
  • Phone:VoIP via ISP

Posted 14 October 2017 - 12:19 AM

The flag is being toggled on and off from a keypad function key linked to a task, which applies a rule to toggle to "BeepGarage" flag on and off with successive keypresses (I have attached the fuller picture).

 

Anyhow, further testing leads me to believe there's a problem with the "state machine" for chiming in the M1Gold, and it does not handle the DISABLE CHIME action correctly.

 

My general testing methodology was to:

a.    set the chime state manually from the keypad

b.    simplify my logic to one rule:

      WHENEVER Beep Garage (Task 5) IS ACTIVATED

                  THEN DISABLE CHIME IN Area 1(Area 1)

 

1. Set the chime state to Voice Only from the keypad

 

2. Pressing the function key and activating the above rule results in the keypad button going dim and displaying with a red cross, and the system announces "Chime is Off" - the rule appears to have worked.  However it isn't really off - internally it has reverted to Ding Only and it still chimes.  (It doesn’t matter what state you start in (Ding, Voice, Ding/Voice), it always ends-up in Ding Only.)

 

Normally if you repeatedly press the Chime key on the Navigator Touchscreen keypad, it cycles through:

  • "Off" (Chime button is dim and has a small red cross)
  • "Ding Only"
  • "Voice Only"
  • "Ding and Voice"
  • “Off”
  • etc

However, after running the rule that results in the Chime button appearing to be off (and the system announcing Chime is off) pressing the Chime button results in the system saying "Chime is Off" (and this time, it really is off) – whereas a button press in a “real” Off state should change it to the Ding Only state.

 

Other times, one press on the Chime button in this supposedly "Off state" results in it going into the Voice Only state (which is the normal sequence after the Ding Only state).

 

I suspect that the variation in what state it goes into after a further button press (ie the 2 paragraphs above) is related to the 20 second timeout on Chime button pressing.  That is, if you keep hitting the Chime button within 20 seconds of the last button press, it goes through the cycle above.  However, if you wait longer than 20 seconds for another button press, it always goes to the Chime Off state.

 

I can’t see a work-around until the bug is fixed.  (I guess I don’t need a function key at all – I can just enable/disable chime from the Chime button.)


Edited by steerage250, 14 October 2017 - 12:42 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users