Jump to content


Photo
- - - - -

Upgrading firmware on Elk M1 Gold components


  • Please log in to reply
3 replies to this topic

#1 Albert Gyomber

Albert Gyomber

    Newbie

  • Registered
  • Pip
  • 8 posts

Posted 23 September 2017 - 09:11 AM

Hello Everyone,

 

I have an M1 Gold that I'd like to upgrade to the most recent bootware/firmware but I'm not sure how to proceed. I have an M1EXP, M1XRF2G and an M1KP2. Can someone advise the correct order in which I should upgade? Also, isn't a version of the M1 firmware no longer compatible with the M1XRF2G? Please see attached screenshot for devices bootware and firmware versions.

 

Thanks in advance!

 

--AJ



#2 wuench

wuench

    Cocoonut

  • Registered
  • PipPipPipPip
  • 1603 posts
  • Location:St. Louis, MO
  • Experience:guru
  • Software:Harmony, Open Source Automation
  • Hardware:Elk M1, ISY-99
  • Tech:INSTEON, Z-Wave
  • Audio:Sonos
  • Video:Custom
  • CCTV:ip
  • Phone:OBi100/110

Posted 23 September 2017 - 09:39 AM

I think usually it is ElkRP/Bootware/Firmware/Modules but follow the instructions in the release notes for the versions you are upgrading to.


Edited by wuench, 23 September 2017 - 09:40 AM.


#3 RAL

RAL

    Cocoonut

  • Registered
  • PipPipPipPip
  • 1771 posts
  • Location:Rhinebeck, NY
  • Experience:average
  • Hardware:Elk M1
  • Tech:X10-PLC
  • Phone:POTS

Posted 23 September 2017 - 12:11 PM

Hello Everyone,

 

I have an M1 Gold that I'd like to upgrade to the most recent bootware/firmware but I'm not sure how to proceed. I have an M1EXP, M1XRF2G and an M1KP2. Can someone advise the correct order in which I should upgade? Also, isn't a version of the M1 firmware no longer compatible with the M1XRF2G? Please see attached screenshot for devices bootware and firmware versions.

 

Thanks in advance!

 

--AJ

 

 

The current/latest firmware level for the M1 is 5.3.10.  The latest bootware is 3.3.6, which you appear to have.

 

You're correct that support has been dropped for the M1XRF2G, starting with level 5.3.x.  But the M1XRFEG is still supported..

 

If you want to keep using the M1XRF2G, the last firmware level that supported it is 5.2.10.

 

Unless you are having a problem, or there is a known bug that you need to avoid by doing an upgrade, the usual recommendation is to leave things alone.



#4 DELInstallations

DELInstallations

    Cocoonut

  • Professionals
  • PipPipPipPip
  • 5400 posts
  • Software:Custom
  • Hardware:Custom
  • Tech:ZigBee
  • Audio:Custom
  • Video:Custom
  • CCTV:analog, ip, dvr

Posted 26 September 2017 - 06:32 PM

Can't remember, but I believe the M1 can only be firmware upgraded to a certain level if a RF2G is installed on it.....I'd have to dig through the release notes.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users