Jump to content


Photo
- - - - -

secure connection


  • Please log in to reply
4 replies to this topic

#1 autonow

autonow

    Newbie

  • Registered
  • Pip
  • 4 posts

Posted 24 February 2019 - 01:08 PM

I have had my elk m1 working for about 7 years and now have a problem. I can not connect. If I use the web  (after unblocking java) I get a Can not establish secure connection message after java loads. I read the forum responses to this problem and think it may be java related because java is always screwing with what used to work!

 

So I tried ELKRP again always reliable until now. I am on my local network with the elk. When I try to connect I get a "could not establish a secure connection" error message. I am frustrated because it has always worked in the past.

 

Any Ideas?

 

Also how do you stop site from logging you out before you can post topic!!



#2 lanbrown

lanbrown

    Cocooner

  • Registered
  • PipPip
  • 55 posts
  • Software:Indigo
  • Hardware:CaddX
  • Tech:Z-Wave

Posted 24 February 2019 - 02:37 PM

You mentioned Java, newer versions of Java make using self-signed certs a little harder to use.  I would suggest you start there and start searching for the Java version you're using and how to get it to accept self-signed certs for your particular OS.  You will probably need to add that self-signed cert as trusted.



#3 mikefamig

mikefamig

    Cocoonut

  • Registered
  • PipPipPipPip
  • 3422 posts
  • Experience:novice
  • Hardware:Elk M1
  • Tech:UPB
  • CCTV:ip

Posted 24 February 2019 - 04:14 PM

I know nothing about connecting from the web but are you running ElkRP on Windows 10?  If you are then read this:

 

https://www.elkprodu...s-compatibility

 

Or install ElkRP on a Win7 or XP machine.

 

Mike.



#4 autonow

autonow

    Newbie

  • Registered
  • Pip
  • 4 posts

Posted 02 March 2019 - 03:11 PM

An Update.. Lets focus on using elkrp. Running win 7. Always worked in the past.... I have directly entered the "local" ip address of the m1xep (not a name) I can connect on port 2101 the non secure port. So it tells me the Ethernet connection and module are working. But I can not connect on port 2601 the secure port,  Since I am on the same network and enter the ip address routing should not be an Issue. Still get the error can not establish a secure connection. Yes port 2601 is the secure port entered in the m1xep configuration.

 

Any ideas?



#5 RAL

RAL

    Cocoonut

  • Registered
  • PipPipPipPip
  • 1961 posts
  • Location:Rhinebeck, NY
  • Experience:average
  • Hardware:Elk M1
  • Tech:X10-PLC
  • Phone:POTS

Posted 02 March 2019 - 08:00 PM

What firmware level are you running on the M1XEP?

 

The M1XEP used to use SSL protocol for the secure connection, which was supported by Windows and also the various browsers.  But security flaws were discovered in SSL, and it has been abandoned in favor of TLS protocol.   Windows and the browsers continued to support SSL for a while, but no longer do.

 

It's possible that your Win7 system installed updates somewhere along the way and thus SSL will no longer work with the M1XEP.

 

The fix is to install firmware level 2.0.42 to switch the M1XEP over to using TLS.  Depending on how back level your XEP is, you may need to also install a new level of bootware.  If your XEP is very, very back level you may need to install an interim version.  Read the release notes carefully.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users