Jump to content


Photo
- - - - -

Omni Pro II - remote access troubles with SnapLink and Google WiFi


  • Please log in to reply
3 replies to this topic

#1 AnakinsPants

AnakinsPants

    Newbie

  • New Member
  • Pip
  • 1 posts

Posted 02 May 2019 - 10:16 AM

Hi all, hoping you can help with a networking issue.

 

I have an Omni Pro II controller with networking up and running. Inside my local network, I can ping the board, I can access via SnapLink and PC Access without issue and everything works fine at all times.

 

My router is a Google WiFi.

 

For some reason, the Omni controller never shows up as an active device in my router and GWF requires a device to be 'active' before you can setup port forwarding, DHCP reservations, etc.

 

So, I went through some convoluted steps to spoof my controller board MAC address on a pc, setup a reserved IP and subsequently a port forward. Everything worked for a few days.

 

After those few days, the controller entry in my device list in GWF disappeared (as though the device went idle) and the port forward no longer works so i can't access remotely. The port forwarding and DHCP reservations are still there in GWF, just the device isn't showing.

 

Has anyone dealt with a scenario like this and if so, how did you resolve?

 

Appreciate any feedback, thanks!

 

 



#2 lanbrown

lanbrown

    Cocooner

  • Registered
  • PipPip
  • 78 posts
  • Software:Indigo
  • Hardware:CaddX
  • Tech:Z-Wave

Posted 02 May 2019 - 04:38 PM

Some companies don't understand networking but make network products.  On my alarm panel the network interface would try to get a new address rather than renew the exiting lease; so its IP would change.  If you make a config change to the panel it would perform a soft reset of the interface would then get a new IP address.  Some DHCP servers allow a new address to be assigned rather than the same IP.

 

Have you tried a DHCP reservation for the Omni Pro network interface?  Also some devices don't give a name in the DHCP reservation and some routers require a name so it can show the various devices on the network.  Unfortunately there probably isn't much you can do about that if that is the real issue.



#3 LQtechvn

LQtechvn

    Dedicated Cocooner

  • Registered
  • PipPipPip
  • 150 posts
  • Hardware:HAI OmniPro II
  • Audio:HAI
  • CCTV:ip, dvr

Posted 03 May 2019 - 02:14 AM

Controller IP alway is static IP. I recommend set Controller IP out of range DHCP to except IP address conflict with other (set IP by OmniKeypad). 



#4 pete_c

pete_c

    Cocoonut

  • -=Gold Supporter=-
  • 9400 posts
  • Location:House
  • Experience:average
  • Software:Main Lobby, Open Source Automation
  • Hardware:HAI OmniPro II, Mi Casa Verde Vera, Ocelot
  • Tech:X10-PLC, X10-RF, UPB, INSTEON, Z-Wave, ZigBee, 1-Wire, xAP, xPL, ALC
  • Audio:Russound
  • Video:MythTV
  • CCTV:analog, ip, dvr
  • Phone:Asterisk, FreePBX, Ooma, POTS, VoIP via ISP

Posted 05 May 2019 - 01:07 PM

Welcome to the Cocoontech forum AnakinsPants.

 

I am not familiar the Google WiFi combo router Wireless access point.  Most combo routers are the same.

 

The OmniPro panel does not do DHCP and because of this you cannot utilize DHCP reservation.  It talks only at 10Mbs 1/2 duplex fixed.

 

Configuring the IP of the OmniPro panel and port access from the WAN should be all you need to do on your combo router.

 

If you can adjust a single LAN port setting on your combo router try maybe to set it to 10Mbs 1/2 duplex and shut off autonegociate on that specific port.

 

 

 

That said you can test some by putting the OmniPro IP in a DMZ for a bit and see if you can access it.

 

Some routers have rules sets for ports to the LAN side and port access on the WAN side versus one setting for both the LAN and WAN side.

 

Also set the port access for both TCP/UDP.  Also enable NAT loopback such that you can test your WAN access IP from the inside of your network.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users