Jump to content


Photo
- - - - -

Celsius Help (Elk M1)


  • Please log in to reply
1 reply to this topic

#1 Superjer2000

Superjer2000

    Cocooner

  • Registered
  • PipPip
  • 64 posts

Posted 18 June 2019 - 11:37 PM

I had stopped using my Z-Wave Thermostats from the Elk (CT-100s connected via M1XSLZW and VRC0P-1LW) a while ago due to the information being reported in the Elk in Fahrenheit where it should be (and I think USED TO BE (although I haven't done anything with them for a while) in Celsius).  I recall that Rules that use Elk Custom Values needed to be in Fahrenheit.

 

Anyways, long story short:

 

1. I have the Global Setting 4 in the Elk set as Celsius

2. M1ToGo still shows the thermostat temperatures in Fahrenheit (i.e. It shows 72 instead of 22)

3. eKeypad also shows the thermostat temperatures in Fahrenheit  (but with a C afterward as the app is configured for Celsius so it shows 72C instead of 72F)

4. Keypads with temperature sensors show the temperature in Celsius properly (22C)

5. The thermostats are configured for Celsius

 

I am unable to change the heat/cooling setpoint temperatures from eKeypad, M1ToGo, or via Rules.  I think the issue is that there is a mix-up between units and so what is being sent is likely out of range (If Elk is configured for Celsius and it might be trying to send 71C to the thermostat (potentially converted into Fahrenheit, causing the value to be out of range.).  I can control the fan and mode of the themostats from eKeypad or M1ToGo.

 

As noted, this used to work a few years ago (although I was using different RadioThermostat thermostats (CT-32s).  I'm not sure if there is a firmware bug (I'm running 5.2.10), but I can't see any change logs on Elk's site for prior firmware releases before the last one.

 

I've searched on this issue but to no avail.  Any ideas?

 

Thanks!!



#2 Superjer2000

Superjer2000

    Cocooner

  • Registered
  • PipPip
  • 64 posts

Posted 29 June 2019 - 01:17 PM

Hi - It seems like nobody else has encountered this problem before.  Would anybody have the prior Elk M1 firmware change logs and could check to see if there were any fixes related to temperature units for thermostats made?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users