Jump to content


Photo
- - - - -

SSH issue to DSL AT&T connection


  • Please log in to reply
2 replies to this topic

#1 pete_c

pete_c

    Cocoonut

  • -=Gold Supporter=-
  • 9502 posts
  • Location:House
  • Experience:average
  • Software:Main Lobby, Open Source Automation
  • Hardware:HAI OmniPro II, Mi Casa Verde Vera, Ocelot
  • Tech:X10-PLC, X10-RF, UPB, INSTEON, Z-Wave, ZigBee, 1-Wire, xAP, xPL, ALC
  • Audio:Russound
  • Video:MythTV
  • CCTV:analog, ip, dvr
  • Phone:Asterisk, FreePBX, Ooma, POTS, VoIP via ISP

Posted 24 July 2019 - 04:24 AM

Help?

 

I built a new Ubuntu 18.04 box to function as an automation server for a peer in Atlanta.

 

It ran fine here for weeks updating and upgrading it.

 

The Verizon combo DSL modem is configured to allow SSH (port 22).

 

Did a speed test there and see a 38ms ping time (high) and IP6 running.

 

Initial issues was that it kept dropping my ssh connection.

 

Configured the time out for SSH and it worked and doesn't disconnect me.

 

Only now the SSH session is really slow.

 

So I switched to using only IP4 for SSH....which did not help.

 

Doing an Ubuntu Update (not upgrade) takes hours and it appears to keep disconnecting from the Ubuntu servers.

 

I have been able to get to the router config and noticed that the GUI is really slow...never seen this before.

 

I have faster SSH connections to the EU / UK and Pacific Rim (Australia / New Zealand) than this Atlanta connection.

 

The last server (in ATL) eventually trashed two SD cards during these slow intermittent connection issues so I started all over again.

 

Any suggestions to fix this?

 

 

Update: 0625 C time

 

Using a remote desktop connection (Radmin) locally SSH'd to automation server and tried doing an update via SSH from the desktop.  It is just as slow are remoting to computer from the midwest via SSH.

 

 



#2 giesen

giesen

    Dedicated Cocooner

  • Registered
  • PipPipPip
  • 121 posts
  • Experience:average
  • Software:Harmony
  • Hardware:Elk M1, ISY-99
  • Tech:INSTEON, Z-Wave
  • Video:Custom
  • CCTV:ip
  • Phone:Asterisk, FreePBX, POTS, VoIP via ISP

Posted 24 July 2019 - 09:54 AM

Sounds like an MTU issue. Is the Verizon modem/router combo configured with the correct MTU and TCP MSS clamping? Sent from my SM-N9500 using Tapatalk

#3 pete_c

pete_c

    Cocoonut

  • -=Gold Supporter=-
  • 9502 posts
  • Location:House
  • Experience:average
  • Software:Main Lobby, Open Source Automation
  • Hardware:HAI OmniPro II, Mi Casa Verde Vera, Ocelot
  • Tech:X10-PLC, X10-RF, UPB, INSTEON, Z-Wave, ZigBee, 1-Wire, xAP, xPL, ALC
  • Audio:Russound
  • Video:MythTV
  • CCTV:analog, ip, dvr
  • Phone:Asterisk, FreePBX, Ooma, POTS, VoIP via ISP

Posted 24 July 2019 - 10:05 AM

Thank you giesen.
 
I was on the router earlier this morning and did the following:
 
1 - changed DNS from AT&T defaults to 8.8.8.8 and 8.8.4.4
2 - shut off IP6
 
I am not used to tinkering with this router as last ISP provided router I played with was a Verizon FIOS router a few years back.

I am today only used to playing with the PFSense firewall (and purchased Surfboard modems)
 
Will have a look at MTU and TCP MSS clamping.  I have seen the MTU settings but not the TCP MSS clamping settings.
 
This morning suggested to user to switch over to XFinitiy cable versus the DSL copper he is using.

 

That and messed up my ssh connection via the SSH configuration on the automation box such that I cannot get to the box now.

 

I was using an ssh reverse proxy to get to the firewall and other devices on the network.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users