Jump to content


Photo
- - - - -

Newbie WEBSET questions


  • Please log in to reply
3 replies to this topic

#1 epfunke

epfunke

    Newbie

  • Registered
  • Pip
  • 3 posts

Posted 23 July 2020 - 07:50 PM

I am having trouble sending the value of a VAR from one wc32 board to another.  Both are on the same lan, both V4.02.18.

 

One of the 2 boards has been reliably sending values to my ISY, and I found examples of what to put in the webset URL to talk to isy.

 

What would I put in the webset URL on the first WC32, to set VAR1 on the second WC32?

 

I have the ip addresses correct, and I have the encoded username/password sting in that field.

 

Any help would greatly appreciated.  and if there is a good explanation of this, or a tutorial somewhere please point me to it.

 

 

Thanks and have a great day

 

Eric



#2 epfunke

epfunke

    Newbie

  • Registered
  • Pip
  • 3 posts

Posted 25 July 2020 - 06:55 AM

I finally got this working and wanted to post what I found.  From section 3.3 of the programming manual on page 35

 

to manually set a VAR value from outside....

 

 

so I put /api/setvar.cgi?varid=1&value=  in the webset URL

 

and called WEBSET URL1 VAR1 in the plc program  and the value of VAR1 was sent VAR1 in the second wc32 board



#3 Tschmidt

Tschmidt

    Dedicated Cocooner

  • Registered
  • PipPipPip
  • 186 posts
  • Location:Milford, NH
  • Experience:novice

Posted 29 July 2020 - 08:12 AM

Glad you got it working. Took me a while to figure out how to use the webset command, the user manual is not very clear about details. Note, the source register can be different then the destination register set in the Webset URL.

 

Something to keep in mind is the destination should verify info is current. In my case I send the info every minute and at the destination if the value has not been updated in 10 minutes consider it unreliable and revert to plan B.

 

/tom



#4 LarrylLix

LarrylLix

    Cocoonut

  • Registered
  • PipPipPipPip
  • 1520 posts
  • Location:Bethesda, Ontario
  • Experience:guru
  • Software:Custom
  • Hardware:ISY-99, Custom
  • Tech:INSTEON, 1-Wire, Custom
  • Audio:Custom
  • CCTV:ip
  • Phone:Ooma

Posted 29 July 2020 - 01:06 PM

This is a common problem with so many native Mandarin language translations to English in manuals. At times, the same paragraph can contradict itself in what appears to be a direct translation of words that may not follow English grammar rules.

 

I am going to suggest a manual suggestion thread or other input place for experienced English and experienced users to suggest wording changes, in order to improve the overall experience and help promote ease of usage and education for the product.


Edited by LarrylLix, 29 July 2020 - 08:17 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users