Jump to content


Photo
- - - - -

Elk Rule


  • Please log in to reply
8 replies to this topic

#1 Scrambled

Scrambled

    Dedicated Cocooner

  • Registered
  • PipPipPip
  • 182 posts
  • Location:Paris, KY

Posted 30 November 2007 - 02:07 AM

I am trying to make my wife happy, so this is kinda important if I want more money for my toys.

Ever since my wife and I moved into out house, the master bedroom temperature has been off. It has either been too hot in the summer and too cold in the winter.

We tried closing some of the dampers, adjusting register vent, still nothing.

That is when I came up with the idea of kinda cutting the main floor HVAC system in half. An as strange as it sounds it actually works great! For the first time my wife told me the bedroom was too hot in the winter!!!

Now to the point. -- She is too hot.

I am ordering a second RCS zone controller to do this the correct way with a t-stat in the bedroom, so this is just until parts get here.


I want output #7 to turn on at 10, 11, 12,1,2,3,4,5,6 during the night and run for 35 minutes. Then turn off for 25 minutes.

I have a statement that anounces the time, so I don't have to watch the clock to know when the damper is going to close.


The way I have this written now, the output turns on, and it does not turn back off until 7:00 am. I have tried everything, except the obvious-- What am I missing??



WHENEVER THE TIME IS 11:00 PM
THEN ANNOUNCE Say Time (vm238)
THEN TURN M bedroom HVAC (Out 7) ON FOR 35 MINS
4
WHENEVER THE TIME IS 12:00 AM
THEN ANNOUNCE Say Time (vm238)
THEN TURN M bedroom HVAC (Out 7) ON FOR 35 MINS
5
WHENEVER THE TIME IS 1:00 AM
THEN ANNOUNCE Say Time (vm238)
THEN TURN M bedroom HVAC (Out 7) ON FOR 35 MINS
6
WHENEVER THE TIME IS 2:00 AM
THEN ANNOUNCE Say Time (vm238)
THEN TURN M bedroom HVAC (Out 7) ON FOR 35 MINS
7
WHENEVER THE TIME IS 3:00 AM
THEN ANNOUNCE Say Time (vm238)
THEN TURN M bedroom HVAC (Out 7) ON FOR 35 MINS
8
WHENEVER THE TIME IS 4:00 AM
THEN ANNOUNCE Say Time (vm238)
THEN TURN M bedroom HVAC (Out 7) ON FOR 35 MINS
9
WHENEVER THE TIME IS 5:00 AM
THEN ANNOUNCE Say Time (vm238)
THEN TURN M bedroom HVAC (Out 7) ON FOR 35 MINS
10
WHENEVER THE TIME IS 6:00 AM
THEN ANNOUNCE Say Time (vm238)
THEN TURN M bedroom HVAC (Out 7) ON FOR 35 MINS
11
WHENEVER THE TIME IS 7:00 AM
THEN ANNOUNCE Say Time (vm238)
THEN TURN M bedroom HVAC (Out 7) OFF



thanks for the help



Steve

#2 aehusted

aehusted

    Dedicated Cocooner

  • Registered
  • PipPipPip
  • 170 posts
  • Location:South Jersey

Posted 30 November 2007 - 09:26 AM

is that possible?

Now to the point. -- She is too hot.



#3 upstatemike

upstatemike

    Cocoonut

  • Registered
  • PipPipPipPip
  • 3340 posts
  • Location:CNY
  • Experience:novice
  • Hardware:Elk M1, HomeTroller, ISY-99, StarGate
  • Tech:INSTEON
  • Audio:Sonos
  • CCTV:ip
  • Phone:POTS

Posted 30 November 2007 - 10:41 AM

I am trying to make my wife happy, so this is kinda important if I want more money for my toys.

Ever since my wife and I moved into out house...


If you want to make her happy you probably shouldn't make her live in an outhouse!

#4 aehusted

aehusted

    Dedicated Cocooner

  • Registered
  • PipPipPip
  • 170 posts
  • Location:South Jersey

Posted 30 November 2007 - 10:48 AM

on a more serious note, you may want to check out the DIY zoning project here.
As I recall, there is lots of good information there, even if you are not using their system.

#5 123

123

    Cocoonut

  • Registered
  • PipPipPipPip
  • 1978 posts
  • Location:Montreal, QC
  • Experience:average
  • Software:Premise
  • Hardware:Elk M1

Posted 30 November 2007 - 11:44 AM

I can't see anything wrong with the rules ... but I'm no expert in Rules programming.

The only thing, and this is a long-shot, is this article that talks about the pitfalls of using a time period that crosses through midnight. The M1 restarts its date/time calculations at midnight. I don't think it the cause of your problem ... but worth knowing.

#6 AnotherOne

AnotherOne

    Dedicated Cocooner

  • Registered
  • PipPipPip
  • 208 posts
  • Location:Seattle
  • Experience:average
  • Software:Custom
  • Hardware:Elk M1, Custom
  • Tech:Custom
  • Audio:Custom
  • Video:Custom
  • CCTV:analog

Posted 30 November 2007 - 01:00 PM

Make sure you don't have any other rules referencing output 7. I had a similar problem with an output, then found the problem - I renamed an output, but didn't remove the reference to the old name - so it just changed it to "output #".

You could also add a rule:

WHENEVER THE TIME IS 11:59 PM
AND OUT 7 IS ON
THEN ANNOUNCE something.

#7 Spanky

Spanky

    Cocoonut

  • Manufacturers
  • PipPipPipPip
  • 2482 posts
  • Location:Hickory, NC USA
  • Experience:guru
  • Software:Custom
  • Hardware:Elk M1
  • Tech:X10-PLC, X10-RF, UPB
  • CCTV:ip
  • Phone:VoIP via ISP

Posted 30 November 2007 - 01:04 PM

I tested a single rule that turns on an output for 1 minute and it does turn off.

Do you have any other rules that could be turning on output 7? If you turn on the output while it is timing down, the timer will be canceled.

Disable all the turn on Rules except one and adjust its turn on time for the next minute. See if it works alone.

In this case crossing from nite to morning should not make any difference.

Edited by Spanky, 30 November 2007 - 01:08 PM.


#8 Scrambled

Scrambled

    Dedicated Cocooner

  • Registered
  • PipPipPip
  • 182 posts
  • Location:Paris, KY

Posted 03 December 2007 - 10:58 AM

Spanky-

I disabled all but 1 rule and it still worked the same way. The output would not turn off.

I changed my rules to--- 10:00 p.m. output turns on (with out the duration)
10:35 p.m. output turns off

It seams like I have to have an off command. The second set of rules works great.


Any idea?



Steve

#9 Spanky

Spanky

    Cocoonut

  • Manufacturers
  • PipPipPipPip
  • 2482 posts
  • Location:Hickory, NC USA
  • Experience:guru
  • Software:Custom
  • Hardware:Elk M1
  • Tech:X10-PLC, X10-RF, UPB
  • CCTV:ip
  • Phone:VoIP via ISP

Posted 04 December 2007 - 08:44 AM

Something is cancelling the output timer. You should not need an OFF command on the output, but that would work.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users