'bout ready to call it quits

jrfuda

Active Member
Last night my Viewpad's HDD failed - AGAIN, I just replaced it 6 weeks ago. It must be too hot in there for it. (last episode here: http://www.cocoontech.com/index.php?showtopic=773 )

I decided to recover what I could from it using my USB 2.0 external HDD case. I had problems using this with my HS Server (the only USB 2 capable machine I have) do to a BIOS problem that had since been rectified buy an update I made several weeks ago - however I still needed to enable to feature (called "USB 2.0 COMPATIBLE in the BIOS chipset sub menu) for it to work. I did not want to do the imaging on one of my other PC's that are all slow USB 1.1, because it would take forever.

Now, my HS Server doesn't have a keyboard, I always RDP to it, but to get to the BIOS I need to install a keyboard. I have an old unreliable keyboard I use just for this. I powered the PC down, plugged in the keyboard and hit the DEL key when prompted, apparently the keyboard was acting flaky again and didn't send the DEL, so windows started booting. I was in a rush so I stopped windows from booting (shame on me). I plugged in a good keyboard, entered the BIOS, made the change and rebooted. Now the PC can't boot from the HDD. I tried a few recovery tricks, but they did not work. I even tried to perform a repair installation using my XP Pro install disk and got the message, when it displays the possible partitions to install to " (setup cannot access this drive) ", which means something bad happened to it. Acronis True image couldn't access it either. I must have reset the computer at the exact instant the HDD was doing something critical and killed it. So now my house has gone form 3 working PCs to 1.

I think I'm going to lay off Home Automation for a while, I don't have the time to fix 2 PCs - essentially having to reinstall everything on my HS Server (I have a true image DVD backup that is about 4 weeks old, that would get me most of the way there, but I still need a HDD). There's just too much going on for the next couple of months, projects, exams, Christmas, etc. I guess this means the Christmas lights will be on old-timey timers this year.

Unless something happens that enables me to get my system up lickity-split, of course.

If I'm currently working on a project with you, I'll still be able to finish my part, I just wont be able to test the output. Also, all the links to downloads from my sight are broken.
 

jrfuda

Active Member
I may try this: http://www.nu2.nu/pebuilder/ and see if I can use this to fix my drive (if it's not an actual HW failure). Or at least receover the files that have changed since the last image. This may be the lickity-split fix I need, if not, then back to waiting for some time to present itself.

By the way, I have read a lot of good things about the various incarnations of Bart's Boot Disk http://www.nu2.nu/ , perhaps all of us should make one and keep it handy.
 

electron

Administrator
Staff member
That HD was on its way out already if all you did was just rebooting it, I interrupt my windows bootups all the time without any issues, you are mostly reading from the drive, so that shouldn't be an issue. I do understand the frustration, and you probably do need a break, I have been there many times. If there is anything we can do, let us know! Everyone knows you will be back soon, that's just the way HA works!
 

jrfuda

Active Member
After 1 day of no automation, my wife is already missing it. This is a small victory for all us automaters, and will perhaps accelerate my repair timeline.
 

electron

Administrator
Staff member
I just saw your PEbuilder post, this is what I built with some of those PEbuilder components:

 

jrfuda

Active Member
E, Very nice!

The first PE builder disk I made had a glitch in it - got all the way to the PE desktop and then couldn't find a file.
 

jwilson56

Senior Member
We have all been there at one time or another. I gave up home automation at least twice now!!! lol

A couple years I lost the drive and a week later lost the Slink-e and then 2 weeks later I lost the MR-26. Somedays it just doesn't pay to use computers!! Some days I swear I am going to live with the Amish.

Just keep going cause there is no going back to no automation.

John
 

electron

Administrator
Staff member
It's a fact, we either want to be a high tech HA geek, or Amish, I am going through X10 hell right now, but man, when I remove some of the key components, the wife complains it's missing, and it feels like an empty void. You just need to be 'push started' again, just like an older manual car where the starter died ;)
 

PaulH

Active Member
Did you try booting to a floppy disk with fdisk.com on it and then at the DOS prompt type FDISK /mdr?

This rebuilds the master boot record from the duplicate copy saved to the HDD.

It does no harm to try it, it just might work for you.
 

jrfuda

Active Member
PaulH said:
Did you try booting to a floppy disk with fdisk.com on it and then at the DOS prompt type FDISK /mbr...
Ahh, This PC has no floppy disk drive.

Dan suggested I may be able to do the MBR repair through the Windows setup disk repair console, though.

If not, I should be able to do it with the BartPE bootdisk. I think the error I encountered using it the last time was due to burning the ISO to some cheapo media.

I also think I need a Win98/Me boot disk to do the FDISK /mbr thing. I don't think it exists on XP boot disks.

Rupp Thjere's a stray character in Dan's URL, here's the correct one: http://www.marstracker.com/gallery/personal/prometheus.jpg
 

Micah

Active Member
If it makes you feel any better about an hour after reading your post and going, "well that sucks" the motherboard on my main rig died. ;)

you have my sympathy :p
 

jrfuda

Active Member
GREAT NEWS EVERYONE!!!!

I tried every software title d boot disk I could think of, none worked.

I finaly went to Acronis and downoaded the demo for Disk Director.

I created a boot CD, ran it in my HS Server and it told me it could recover the HDD. It wouldn't however, let me actually do it since it was a demo version.

About 10 minutes and $49.99 later, I ran the full version, recovered the HDD and am up and running again.

Now to fix that darn Viewpad!!!

Oh yeah, and time to take those silly manual timers off of the Christmas lights and put some X10 modules on them :lol:
 
Top