Caddx troubleshooting? Think I have a bad keypad...


Senior Member
Have 2 partitions - the house and detached garage. When entering the garage this morning the keypad started beeping but was somehow locked up. I powered down that partition (on an expander) to stop the noise and it never called in an alarm. I powered it up and it seemed to work but showed a fire circuit error. Those seem to happen sometimes when powering up cold. I hit the sequence to reset that and it didn't work. The keys seemed to register but it didn't reset the fault. Had to leave it unpowered. When I tried to arm my house system it had errors and went a bit nuts so I pulled power to it. Suspect since they share the keypad bus the garage failure may be affecting the house partition.

I plan to take one of the keypads in the house and put it in the garage to get things going and confirm it's the garage keypad. I don't have much hope of being able to repair the keypad. Anyone ever do any repairs on them?

It looks like the line went from Caddx to GE to UTC and is still being made? Want to confirm it's the keypad before ordering parts.
Have moved some keypads to test things and the house partition is now working. Not sure what happened. The garage keypad is now working - displaying normally instead of the top line showing all filled blocks and can access programming, etc but still not behaving like expected. Maybe the time it was powered down overnight reset something that the short power down times didn't... But now I have the strange situation that the garage keypad says it is ready and doesn't show not ready when I open a door. I can arm the keypad and it shows armed (after the arming delay) but still not affected by the local sensors. I checked the partition of the keypad and the zones and they seem to be properly set to partition 2. When I input *1 on a house keypad to temporarily change to partition 2 it beeps at me suggesting it doesn't recognize or allow that.

Any forums for this system that allows DIY people?
It seems the zone expander NX216E is not properly reporting the zone inputs. Maybe it is placing them at different zones than the dip switch settings should. I switched the switches thinking the connections may be bad and that might fix them but still the same. Not sure how I would check that the board is functioning properly.
Yes, the main panel is an NX8e. Thanks! I will try there although I see the last activity in the Caddx area is about a year old.
Where is a reputable place to download DL900 software? I have the port and cable but haven't ever used the software. Thinking it might show what boards are in the system and some details that might help me figure out the issue.
Turns out I have DL900 on my PC and forgot about it. Got it about 5 years ago and never did much with it. Time to get it out and see what I can do. I did see something online about DLX900 for win10 but this is on win 10. I will see how well it works...
Substituted a spare zone expander board and still doesn't see the zone inputs. Have a call with the monitoring company tonight to troubleshoot.
It is now saying the battery is low but the battery is fine and runs the system when the AC fails. Might try the zone expander directly in the main can so the remote power board is out of the circuit just to test the board.
Did a bunch of fiddling with things with no luck. Talked to Alarm Relay tech and couldn't figure what was happening although we did a bunch of testing and checking settings. I put the panel from the detached building next to the main panel and put a jumper wire to simulate the door switch to save having to run back and forth and waste a lot of time as its about 250 feet away. Elevated to senior tech a few days later. Powered up the system and everything worked. ??? One thing I realized is I should power up the expander first as the main panel checks what is connected at power up. BTW, the alarm relay tech support was no charge - really happy with their support.