Can I move Elkaccts.mdb file to different location?

The ElkAccts.mdb is located in C:\Program Files\ElkRP folder. I want to move it to my document folder so that my backup software can back it up. Is this possible?
 

IVB

Senior Member
Yea, I did. I moved it to my networked RAID1 disk, then opened it up there so I can use any of 3 PCs to deal with it.
 

Spanky

Senior Member
Under ELKRP/Setup/Options/Files you can change the locations of the .mdb data bases.
 
Under ELKRP/Setup/Options/Files you can change the locations of the .mdb data bases.
'
Thanks for the information. I tried this and got an error message "cannot find operators database or it is not a valid ELKRP operators database"
I moved the OPS.MDB and Controls.MDB database in MY document folder. I also tried to update ELKRP to point to the new location that is when I get the message above. Why does does the message appear when the database is in MY Document folder?
 

gwww

Member
I observed the same behavior as Jamesb. I admit that after I moved to a directory in My Documents I then deleted the stuff from the Program Files directory. In the end I just moved the data back and will do separate back ups for now.
 
There must be something missing on this. I have moved the OPS.MDB and Controls.MDB to MY Document folder it should work. Can someone tell me why this does not work? Do I need to report the bug to Elk?
 

gcimmino

Active Member
Jamesb, what happens if you only move the ElkAccts.mdb file? Even better, copy it first, so there's a copy in both locations. Then use the File/Open Database to open the new copy in My Documents.

I'm guessing that RP tries to open the operators database first and dies if it doesn't find it.

Of course, if you want to live dangerously, you can always move all the files, then just update their locations in the registry. Search for elkaccts and you'll locate the configuration in:

HKEY_CURRENT_USER\Software\VB and VBA Program Settings\ElkRP\Settings

What I did is move the 3 .mdbs Control, ElkAccts and Ops, then update the 3 associated registry entries. The first time I opened RP it complained, then I shut it down and moved the SOps.mdw over too. It seems to need to live with Ops.mdb. RP appears to work fine now.

As always when messing around like this, backup *everything* first. YMMV and I'm not liable for anything! :(
 

gcimmino

Active Member
This might help..

Note that you need the full path to My Documents, yours will vary..
 

Attachments

  • ElkRPRegistry.jpg
    ElkRPRegistry.jpg
    67.5 KB · Views: 23
Top