Can't connect ElkRP to M1



I'm still in the process of installing my new Elk M1 gold. I'm trying to use the ElkRP program. I can't connect ElkRP to the M1.

I thought that it was a cable problem because I had used a cat5 with RJ45 to DB9 module at each end. My cat5 cable was a bit more that 50 feets.

I tryed with the serial cable that came with my w800 without succes. I also tryed with my other pc.

Is there something that must be done with the keypad to activate the M1 serial port?

It's been a long time since I plugged anything in to that port since I use the Ethernet expander, but what if you just connect to the port and run Hyperterm or something? Do you see any data coming out of the control? These things usually turn out to be cable related tho.
I would also start by taking a good look at the serial cable, especially if its using plug-in adapters on the ends like you have. You want pins 2,3 and 5 to be wired straight through from one DB9 to the other. I used an Ocelot serial cable as an extension, which has worked fine. If you have a multimeter, check out the continuity of the pins I listed above.
Bonjour Guy,

I have check my cat5 cable with a cat5 tester and it's ok. I also connect both adaptor by the db9 male-female and i connected my cat5 tester on each side and it's ok too.
I'm sure you are very capable but most issues I remember had to do with the cable. You may want to try a regular factory cable for the heck of it to be sure. Also be sure nothing is running on the pc that would be locking the port. See this thread although not much meat there...
Thank you Steve for the info.

I built two serial cable a long time ago for my Ocelot and my cm11a that are connect to the same computer that i want my Elk to be connect.

Since the Ocelot and the cm11a are on the same wall that the Elk panel, I'll try tonight to connect using these cables.

I'm not sure that the pinout for the Ocelot is the same as the Elk, but i'll try.

On the ELKRP, under SETUP, Communications make sure you have selected the proper serial port.

Under the M1 Global, baud rate settings in the installer programming section using the keypad, make sure the M1 is set for 115000 baud.
Hello everyboby,

I finally connected to the Elk M1!!!

I have use the Ocelot cable that was on port 5 of the PC and I connect it to the M1. I had built this cable myself soldering DB9 to a cat5 using pin 2, 3 and 5.

Since I didn't have any serial port available, I bought a USB serial adaptor at RadioShack (Now called "La Source" here.) and it's working.

Thank you everybody for your help.