• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

Chat not working for mw

jrfuda

Active Member
E,
I can't get chat to work. I've purged my cache and downloaded the latest java, but no luck.
I'm using a laptop with a fresh install of win2k with every swing'n update installed.

I can get the chat window to open, either from cocoon or from the HomeSeer message board..... then the java applet loads and I get a disconnected message. When I connect fromthe HS message board, I can briefly - for about a second - see the list of people in the chat room and then it disappears.

Any idea why this is happening?

Thanks
 

jrfuda

Active Member
Here's what I get when I try to connect:
Code:
Connecting... 
Logging in... 
-irc.marstracker.com- *** Looking up your hostname... 
-irc.marstracker.com- *** Checking ident... 
-irc.marstracker.com- *** No ident response; username prefixed with ~ 
Disconnected from www.cocoontech.com
 

BraveSirRobbin

Moderator
John:

Its because we didn't want you on the chat site anymore :D . HEHE, it appears the java chat is broken right now, was able to connect with IRC chat. I will send E an Email also.

Hey, how was the move? How is the new place treating you? How long you there for?

Talk to you later,

BSR
 

jrfuda

Active Member
I thought you guys might be black-balling me... :D ha ha

I made it to Ft. Leavenworth okay. I'm only here for 5 weeks, then it's back to Korea for a month and then to Texas for a year.

I figured now that I'm in relatively the same time zone as most everyone else, I'd be able to frequent the chat room, well, more frequently...
 

electron

Administrator
Staff member
Glad to see you back on US soil :D I have seen you connect all night, but have been busy so I didn't get a chance to check the boards. It almost sounds like your IRC connection is being disconnected by something on your end, maybe your base's security system is disconnecting any active chat sessions, many place block these kind of connections, eventho I have never seen a connection make it this far before being terminated. Can you try from an Off base computer to confirm this?
 

jrfuda

Active Member
Thanks E, I won't be able to get to an off base machine since my only mode of transportation are my two feet.

I guess I'll try again later. When I first got here I had trouble accessing my POP3/SMTP mail accounts via outlook, but got it to work after a while.

I guess if they're blocking me that I'm out of luck.
 

jrfuda

Active Member
Oh, and another thing, I noticed that the chat client looks for identd, is it benificial to have this installed on my machine? If so, which one should I use, as I've seen several.
 

electron

Administrator
Staff member
Do you have mIRC? A real irc client might help you troubleshoot what the problem is, we will figure this out, no way we can go that many weeks without your presence :D
 

jrfuda

Active Member
I tried connecting with mIRC, here's what I got:
Code:
* Connecting to irc.marstracker.com (6667)
-
-irc.marstracker.com- *** Looking up your hostname...
-
-irc.marstracker.com- *** Checking ident...
-
-irc.marstracker.com- *** No ident response; username prefixed with ~
-
* [10053] Software caused connection abort
-
* Disconnected
Are there any special settings I should use? A shot of the settings I used are in the image attached below.

Sort of per your suggestion I tried from another PC, this time I tried from a PC that I knew for sure was behind a firewall (On of the PCs in a classroom) All I got after the java applet loaded was an error message mentioning port 6667, which is way different than the message I get when I connect from the laptop. The image below contains shots of the messages I get when I try to connect via the web through either the CocoonTech or HS link. When I connected from the PC that I knew was behind a firewall, the only messaage I'd get was the one about port 6667.

Now, I think I might know what the problem is. I'm looking at the box my PC's jacked into it's called a "HPNA Ethernet Bridge." Doesn't HPNA stand for Home Phoneline Networking Adapter? Does that mean that the barracks here are on what big HPNA network behind a router?? IPConfig shows me having a weird IP:
Code:
Ethernet adapter Local Area Connection:

        Connection-specific DNS Suffix  . : xxxxxxxxxx.xxx
        IP Address. . . . . . . . . . . . : xx.xx.x.x
        Subnet Mask . . . . . . . . . . . : xxx.xxx.xxx.x
        Default Gateway . . . . . . . . . : xx.xx.x.x
So maybe that's the problem.

Another thing that is weird, is that when I connect via the HS link, I can briefly (sometimes for up to 3 seconds) see the list of people currently in chat, but it then disappears and is replaced by the screen below. Seems like if the port was blocked that I wouldn't see that at all.

I'm thinking about installing compuserve or AOL on this machine and tring to connect through it... After all this machine's getting reformated when I turn it back in to work in April, so it's not that big a deal.

Off topic now... I just came from the student bookstore they have here. WinXP for $99 a pop, OfficeXP Pro for $199, Macromedia Studio with FlashMX04 Pro for $249, Adobe CS Suite (Every Adobe program in the world) for $399 and it goes on and on. I had a hard time restraining myself. I'm really tempted by the Studio program, it's $1000 for the full (non-educational) version, so $249 is a good deal. And the WinXP is pretty tempting too. I know newegg has it for $89, but I won't have to pay shipping and I can just walk in and buy it!
 

Attachments

  • marstracker2.jpg
    marstracker2.jpg
    87.5 KB · Views: 24

electron

Administrator
Staff member
This is a strange one for sure, unless they are kicking you because of keywords in the disclaimer, I can't figure it out either. HPNA is the system that let's you connect computer using powerlines (kinda like X10), I can't believe that they are using this, anyone could just jack in and sniff the traffic, I suggest you remove the ip config screenshot so you don't get in trouble. Can you give http://irc.marstracker.com a try?
 

jrfuda

Active Member
I googled HPNA and here's what I got:
Also referred to as HomePNA. A de facto home networking standard developed by the Home Phoneline Networking Alliance. This technology, building on Ethernets, allows all the components of a home network to interact over the home's existing telephone wiring without disturbing the existing voice or fax services. In the same way a LAN operates, home networking processes, manages, transports and stores information, which enables the disparate devices in a home network such as telephones, fax machines, desktops, laptops, printers, scanners and Web cameras to connect and integrate over a home's unpredictable wiring topology.

HPNA technology must coexist with telephone service and comply with FCC Part 68.
So it's not the powerline stuff, but I know what you're talking about becuase I remember some discussions about it over in HS land.

I tried the link you suggested, it told me that something java.blah.blah.net was messing something up, so I unistalled Sun Java AND MS .NET stuff from my machine. Now I get this:
Code:
Connecting...
*** Ident server running on port 113
Loggin in...
-irc.marstracker.com- *** Looking up your hostname...
Which seems to be better than what I got before, but connecting via CocoonTech or HomeSeer gives me the same results as before.
 

jrfuda

Active Member
I dialed in through CompuServe and connected to the chat, no problem, so it must be a firewall thing afterall.

I'll have to limit my dialup sessions to only when I want to chat, 'cause it's slowwww.
 

electron

Administrator
Staff member
I'll see if I can install that IRC cgi gateway later today, it just uses HTML, no JAVA or anything, so if you can browse, it will work.
 
Top