CM19a Woes


Man, I am having all kinds of problems getting my CM19a working. I did have this all working at one time with a Visual Basic program which could control a Ninja pan and tilt unit, but that was a while ago. I also changed out computers and operating systems since then.

Here is what I tried so far:

I wanted to use "Case's" CM19a plugin so I could control my X-10 Ninja Pan and Tilt unit from a Homeseer device. After I get this working I wanted to use the Main Lobby Plugin (MLHSPlugin) to control the Ninja via come cool scenes (combined with the camera view).

Anyway, I downloaded Case's plugin and instructions HERE.

I also downloaded the CM19a X-10 drivers HERE (the "x10drivers.exe" file).

I installed the X-10 drivers by just double clicking the executable file, pluged in my CM19a into a USB port (on the computer not a hub), and saw the notice that the new hardware was ready for use. I double checked the device manager and saw that the CM19a was correctly registered as a USB device.

I then copied the hspi_CM19AUSB.ocx file in the Homeseer directory and registered the file using Regsvr32 and saw the dialog box that the ocx file was correctly registered.

I then rebooted the computer, started Homeseer, configured the CM19a as an interface and created a ninja device. I then restarted Homeseer.

It seems like I did everything correctly, yet I can not transmit nor receive anything from the CM19a. I tried reinstalling the drivers, unregistering and re-registering the ocx file, reboot/restart Homeseer, lather/rinse/repeat and could not get this to work.

I also tried this setup on another computer with another CM19a unit (just downloaded the Homeseer trial version on this second machine for testing purposes). All with the same result.

I then tried to include the OCX file as a reference in a Visual Basic program and noticed that the file was not included in the references selection box. So, I'm wondering if the OCX file even got properly registered (even though I got the dialog box saying it was when using Regsvr32).

I tried uninstalling the X-10 drivers (via Control Panel) but it would not go through saying something about a missing log file (stupid X-10 drivers).

Anyone have any suggestions as to what I could try next. This is very frustrating and I wasted a LOT of time yesterday trying to get this to work.


BSR, I'll try to help out on the ninja controls. I have the CM19A hooked to a USB hub (and it's v1.1 to boot) and it works fine. It sounds like you have done the setup right.

1) The one trick that I found was that you HAD to add the ninja devices through Case's plug-in. If they were created in native HS, they would appear correctly, but they would not work.

2) make sure you have "enabled" the right house codes in the interface. I have enabled and retransmit set for the house code that my ninja is on.

3) I use housecode "N" for my ninjas. My cameras are actually on another code and I control the ON/OFF separately.

4) when installing the drivers, I remember that you need to select the I/O for the ninja control.

5) I'll walk you through what I have done to successfully get it working. I've used it for a year or so without problems, and I think I can remember what I did.
-Setup the ninja devices thru the upper part of the interface setup (for N1 thru N16).
-Then go into the event screen, and create an event called "Ninja position 1" and drag down N11 to the bottom. The command for this should then be set to "P1" from the drop-down.
- Similarly setup "Ninja position 2" etc. and drag the respective device down (N12 for this one). The command would be P2 for this one.
- now you should be able to run both of these events to go back and forth as long as you have programmed positions 1 and 2 using the palmpad.

Check your interface section, does it show it as "X10 CM19A Firecracker USB"? The version I am running is v1.0.0. and shows when you have the interface up.

Another note, I find my CM19A disconnects periodically so I send it a command once an hour. I don't believe that there's an issue with this, since if it is disconnected at the time it gets a command it automatically connects.
4) when installing the drivers, I remember that you need to select the I/O for the ninja control.

I didn't get a dialog box for the Ninja control specifically when I installed the X-10 drivers. Did I use the wrong driver file from X-10? Which one exactly did you use?

I did indeed add the Ninja device via Case's plugin and not through Homeseer natively.

Thanks for your help!

I can't remember how it actually asked me for it. I looked in my files, and I have a copy of the x10 drivers that worked. Send me a PM if you want them.

Have you tried to use the ASP page rather than the event setup? That would verify that the CM19A is working....

Are you able to 'see' the right commands when you try to enter them into a device command in an event?
PM sent Jeff.

If you mean am I able to see the Ninja specific commands (left, right, etc...) by right clicking on the Ninja device in Homeseer, going to controls and seeing those specific commands, yes I can see them.
I sent the driver file - it's a meg in size.

If you get the commands visible when you right click, then I believe that the interface is setup ok.

When you "execute" one of these, does the light on the CM19A blink?
BSR, remember that the ninja base actually has to be ON before it will accept a command. I use the power supplies that come with the ninja base and wire them to both the camera and base so they're on the same code. But you have to turn this code ON before sending a LEFT command.
I realize the power supplies need to be on for the ninjas, but I'm not even getting the CM19a light to blink on a command.

I also tried to add the CM19a as the mainHomeseer interface and could not get it to receive anything as well.

I doubt its a problem with the CM19a as I have two units here and tried them both with the same result.

Also, Jeff the Email did not come through!
I just noticed a way to verify that you have the I/O interface setup. In the interface panel, it shows Mode [IO] at the bottom....

HERE are some screen shots of my setup.

BTW: Your Email of the drivers never came through. Can you PM me what Email addy you used?

Thanks again for helping me out with this! ;)

all of those screens look right to me....assuming that your ninja codes are E and N. The only thing I see different from mine is the USB device setup. My firecracker shows as "X10 USB Firecracker Interface V2.36"
Well Jeff, your X10 driver file worked! I did have to reload the drivers again after I had the CM19A plugin setup in Homeseer (weird but that's what it took). I don't know if X10 changed their website, but your driver worked and the one I got off their site did not (your clue of our different descriptions in the device manager is what guided me).

Thanks again for all of your help!! :( I could not have done this without you!!

I incorporated this Plugin into my Main Lobby directory scene (screen shot below).

I read in other posts in HS land that you were having trouble with disconnects. When I click on a camera control I first send that camera's ON command, then the specific Ninja command. Do you think this will solve the disconnect problems?

I also do a "For Next" loop so I don't get those short movements (I believe JohnWPB gave that tip, but I've read soooo many CM19A posts these past two days they are starting to blur).

Here is a sample code for the "LEFT" command:

sub main()
dim step

set objFireCracker = CreateObject("hspi_cm19a_usb.cFireCrackerUSB")
with objFireCracker
     .HouseCode = "N"     
     .Devicecode = "1"  'Ninja1 is N1 House & Unit Code
     .Command = 1      'Turn Ninja1 Camera ON

     For step = 1 to 10   'Value to Repeat Ninja Command
          .Command = 7 'Left Command Value

end with

set objFireCracker = nothing

end sub

This has got to be the NUMBER ONE PITA I have ever set up for any of my home automation projects (and that includes my Caddx NX8E programming).

Oh well at least its working now (after putting in many many hours on this) ;)


  • pantiltdir.jpg
    98.8 KB · Views: 62
BSR, that's great!

I don't think you really need the extra ON command, I would try without it. I use the same method of sending multiple LEFT commands - works nicely.

Glad it worked. Nice ML screen too...
I then copied the hspi_CM19AUSB.ocx file in the Homeseer directory and registered the file using Regsvr32 and saw the dialog box that the ocx file was correctly registered.

where can i find the hspi_cm19ausb.ocx and where is the Regsvr32 ........?

looking for help