• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

Dealer PC Access new version issue

jeff1

Member
I was surprised to see a new version dated Feb 2021.  I updated and the new version crashes immediately when it is run.  I have upgraded with every new version since 1999 and NEVER had an issue.  I wish I would have copied the old version before updating, but with that track record of never having an issue, it did not even occur to me before updating.  Now I can't find any way to get the old version back or support for this issue.  Is there still a support number I can call about this?  Or will it be hard to find anyone at Leviton who can help?  Someone has to be there if they pushed an update out 3 months ago.
 
The event viewer shows an error that starts with CLR, so I have updated .NET runtime, but still no luck.  Does anyone know what version of .NET this is built with?
 

pete_c

Guru
Welcome to Cocoontech Jeff.
 
Tested it last week on a new Windows 10 Pro build and it worked fine.
 
Currently running it on an RDP server running Windows 2016 Standard server.
 
 
 
Thinking it installed Microsoft Visual basic automagically.
 
Install it manually.
 
Microsoft.VisualBasic - Assembly Version: 8.0.0.0
 
Make sure you are running installation in Administrative mode.
 

jeff1

Member
I wonder if it is using an updated VB redist... I will try that.  Leviton tech support has no help for me.  They have even told me that they do not have the previous version of the installer to send me anymore.  That is ridiculous!!!!  If anyone has a link to the last version prior to 2.9.21 I would greatly appreciate it.
 

pete_c

Guru
Here is a link to a previous version from 2015 which when installed will need to be updated to current version.  You will need your old serial number to install this version.
 
PCA
 

jeff1

Member
A little more info... on the machine it is crashing at startup on via debugger (windows 7 machine):
     An unhandled exception of type 'System.NotSupportedException' occurred in System.dll
     Additional information: The requested security protocol is not supported.
 
Debug shows CLR 2.0.50727.  Does pcAccess use .NET 2.x?
 
I tried installing on a Win 10 machine, with the intention of copying over my .pca file and seeing if it works there... but on the Win10 PC is it asking me for a security stamp.  Will I even be able to copy the pca file over and try it or is that file encrypted with a different stamp from my old system?  It has been over 15 years since I did a fresh Dealer pcAccess install... don't remember any of this.
 

pete_c

Guru
Thinking the original security stamp was "password".  I then removed it before loading configuration file.  It's been many years.  The newest version fresh install did not ask for a security stamp on Windows 10.
 
Guessing if you purchased the dealer version for your own use then you removed the security stamp on your old installation; well and maybe the newest free version of PCA only works on Windows 10?
 

jeff1

Member
The latest version is running on win 10 with no error.  Problem is, when iu try to open my pca file from other system, it says invalid security stamp.  I do not recall ever setting one on the old file over 15 years ago.  When I installed on Win 10 just now, i left it blank.  How can I go back and try "password" as the security stamp and see if it opens the pca file?  Where is it saved?  If I uninstall, and reinstall will it ask me again?
 

jeff1

Member
Figured it out.  Just copy the cfg file with the pca file and all is well.
 
So I am out of luck getting this running on my Win7 pc.. they changed something in the required .net or libraries in last update... would have been nice to document that in release notes. Leviton says they don't have old versions either... I am sure they do, but not worth wasting more time pursuing... at least it is running on Win 10.
 
Thank you for the help!
 

ano

Senior Member
jeff1 said:
Figured it out.  Just copy the cfg file with the pca file and all is well.
 
So I am out of luck getting this running on my Win7 pc.. they changed something in the required .net or libraries in last update... would have been nice to document that in release notes. Leviton says they don't have old versions either... I am sure they do, but not worth wasting more time pursuing... at least it is running on Win 10.
 
Thank you for the help!
I discovered this as well. That was the problem.
 

RICKRDT

New Member
Hi Pete ..
I've been foe a while following you all in home automation. Sorry to jump in.

I purchased a hole home automation system
For a home i have been slow building in Mexico.

The system was sold to me in 2012 by a guy out of Denver who went out of business in 2014. Had everything hard wired cat6 .
For audio/video/security 6 bedroom 2 story . finally finished in 2019..(its Mexico)

And for that reason I wanted to stay away from (control4 ,Elon, creston) for fear i wouldn't find anyone to service.
So the idea to stay as open source as possible.

How ever here is the setup he used i was assured passwords and now i fear i ended up with paper weights. But im determined to salvage as much as possible.

1 Hai omnipro 2 with expansion card
2 Nuvo Grand a Conceirto with expansion
3 2 Marantz for sound
4 multiple explode speaker amps
5 he preprogrammed everything on a linux server (can't use locked )
6 he used URC CONTROLERS.. with remotes
Cant use in Mexico must go through a dealer and kinda obsolete
7 an IR switch
8 Video Switch with(link hdmi )balun extenders for tvs
9 Ubiquiti mesh

So we are going down for the first time since 2019 and going to take a stab and trying to hook it up.

I bought a Homeseer troller s6 pro in 2019 .

My question is from what i read in another post ..

Can I use the s6 troller and plugin interface to go straight to the Omnipro 2 with an ethernet..
And bypass the use of PC Access software.
Since i can't find that anywhere.

And second will i also be able also do the same with the Nuvo GC plugin?

My thought was that the Original setup was a Linux server with some proprietary software he was going to use.. to the OMNIPRO 2
And that was the Hardware controlling the sound and security..

Im on my way Monday and would hate to find out that i can't use the Omnipro 2 without
That PCAcces software that no one seems to have.

Thanks in advance
Rick
 

pete_c

Guru
Can I use the s6 troller and plugin interface to go straight to the Omnipro 2 with an ethernet..
And bypass the use of PC Access software.
Since i can't find that anywhere.

 
 
 The Homeseer Omni Plugin only manages the transport to and from the OmniPro panel.  IE: you can create automation events with the software.
 
The Dealer PC Access software is free now and posted above on a MS cloud link.  You still have to program the panel with PCA.  
 
 
Not sure what the Nuvo GC plugin is.  All of the HS3 plugins work on HS4.
 

Drtodd

New Member
I have a quick question regarding the security stamp.  I know where to delete it in my documents.  I'm transferring my pca file to a new computer.  I'm assuming the old computer and the new computer need to have the same security stamp in order to read the file?  If I change the security stamp on the old computer (not sure what my integrator used 11 years ago) I don't think I'll be able to read my old pca file thus not able to get into my Omnipro II.  The company that gave me support has since quit doing so so I'm kinda treading lightly in any changes since the system has been working well but I would like to get my PC Access working on an updated computer before the Win7 computer crashes again.
 
Thanks!
 
Anyone on here we can hire to help with remote tech issues? 
 
Top