ELK M1 and EZ8 Software Upgrade

Spanky

Senior Member
ELK Products, Inc. announces a new software upgrade for the M1 and EZ8 Controllers and the ELKRP Remote Programming Software.

M1 & EZ8 Software Version 4.4.6

ELKRP Version 1.6.12

The software is available for download at the m1dealer.elkproducts.com website.

Read the installation instructions and release notes before installing the software.

If using Firefox Browser, you will need to save the files and rename the downloaded files by adding .exe to the end of the file name.
 

AO-Brandon

Active Member
after upgrading ELK-RP locks up on saves. after clicking save, it will attempt to save for a few seconds, then just lock up. it still saves, but you have to close the program forcefully then re-open it to get it working again. let me know what information you need and i will get it all to you. :angry:

Brandon
 

elcano

Active Member
InsanePhotoGuy said:
after upgrading ELK-RP locks up on saves. after clicking save, it will attempt to save for a few seconds, then just lock up. it still saves, but you have to close the program forcefully then re-open it to get it working again. let me know what information you need and i will get it all to you. :angry:

Brandon
This has been happening to me for the past few days - before doing any upgrade!
 

tuantu

Active Member
Mine is locking the same thing but it started on version 1.6.10 and I reported to Tech Support even sent them my export file but again I received no feedback. It also happened again on 1.6.12.
 

dscline

Active Member
cliffs said:
I might add this update(4.4.6) does fix the wireless zone issues.

Cliff s
Sorry to ask here (didn't see a thread for it), but what wireless issues? I have a problematic zone that happens to be a wireless one, and I've assumed the problem to be a flaky sensor. Is there something I should know before I buy a new one?
 

AO-Brandon

Active Member
as an update to the tech guys i talked to this morning, i un-installed the program completely, re-installed with a fresh copy off of the website of the latest version, then did a recieve all. it saved successfully the first time, but when i added notes to the rules it quit working again.

Brandon
 

cliffs

Member
There was an issue of the wireless zones not being properly initialized
on power on. Sometimes some of the zones only would trip once.
If you have any wireless zones you should use ver. 4.4.6.

The problem wasn't intermittent, they just worked or didn't.

Cliff s
 
Oops, I didn't see this post and started another thread on this topic. This is what I posted. It sure seems that the addition of the rules comments feature is what is causing this issus. With the way Elk has implemented comments, storing them seperately from the rules, can be tricky for Elk to implenent and test.

I recently have been going back through my rules to add comments to make maintaining my rules easier. Since adding comments I have run into an issue where I go to save my database file and the RP software hangs up and I have to kill the RP application. I thought this was a fluke and ended up restoring a prior datbase version and all was well (except the work I had completed that was now lost). One week later after adding a few more comments and creating a variety of additional rules I have run into the same problem. I am at a point where my database is saved and is in sync with what is in the M1 control but my rules comments have shifted around in the rules and now the comments don't match the rules they were created for. I also can't make any changes to any exiting rule, add any rules, or change any comments because if I do the RP software hangs up when I go to save the database.

It appears the logic in the RP software that controls the sequencing and indexing of the comments is somehow getting out of whack which is screwing up my comment placement and also preventing the software from being able to save the file. It seems that using the copy/paste funtion on the rules window may be part of the problem because I noticed some rules being misplaced after doing several of these operations.
 

dbinaz

Active Member
When I go to Snd/Recv and click verify update firmware, no other screen pops up to do anything. just like it ignores my request.

any ideas?
XP SP2
 
Top