Elk M1 / HAI Thermostat Address Question


Active Member
I currently have 2 M1XSP serial expander modules, one is for Insteon and one is for 2 HAI thermostats.

The Elk M1 requires that each bus module of the same type have it's own address 1-16. Each HAI thermostat also requires an address be set on itself.

The manual indicates that setting the M1XSP to address 0 requires the connected thermostats have an address of 1-4. Setting the M1XSP to address 1 requires the connected thermostats have an address of 5-8... and so on up to an M1XSP address of 4.

So my question is, since one of my M1XSP units has the Insteon firmware and one has the normal firmware can they both have an address of 1, or do they require different addresses because the both hardware units are M1XSP?

The M1XSP require different addresses. They are both Type 5, so when the M1 queries the M1XSP, it needs to send a unique address for each module that is a Type 5 Serial Expander.

Put the Insteon M1XSP above the Thermostat module addresses since its operation is not linked to the module address.
Now I get a "Not Enabled" message on the keypad for both thermostats.

My previous working configuration was this:

M1XSP for Insteon address: 1
M1XSP for Thermostat address: 2
HAI Thermostat 1 address: 5
HAI Thermostat 2 address: 6

That worked.

To make the thermostat addresses start with 1, I changed the configuration as follows:

M1XSP for Thermostat address: 1
M1XSP for Insteon address: 9
HAI Thermostat 1 address: 1
HAI Thermostat 2 address: 2

But when I look them up on the keypad, it says:

T01:Not Enabled
T02:Not Enabled

Any ideas?


UPDATE - progress but still not working
I re-enrolled the bus modules and then thermostat 1 showed up, but not 2. I went to thermostat # and realize that it was not setup for pc mode. I changed that setting and then re-enrolled the bus modules and # 2 still shows as not enabled.

I then power cycled the elk and waited 10 minutes and # 2 still shows as not enabled.

Any idea?

UPDATE 2- Working, but I don't trust it
I upgraded the M1XSP firmware from 1.0.20 to 1.0.24 and both thermostat temperatures now show up, however I did not see any mention of HAI in the firmware release notes?

I'm going to keep an eye on it.