Elk M1 & X10 Wierdness


I have encountered a really wierd problem that i am hoping someone can shed some light on as I have can't make any sense of it. here's the situation:

I setup a X10 scene to control 4 lights in my family romm and assigned it an X10 address of M10 and created a lighting entry in the M1 called FR-Scene. I then created an entry for a button on a Keypad Link in the Elk-M1 called KPD-Kitchen-2 at location E6. I then created the following rule in the M1:

THEN TURN FR-Scene [202](M10)] ON

When I press the appropriate button on the keypad all four lights in the family room come on as expected. So far so good.

In addition to activating the scene with the keypad I want too be able to activate it through an IR keyfob (I have a W800 IR receiver). I setup an entry for the keyfob in the M1 at address D1 called Keyfob-1. I then created the following rule:

THEN TURN FR-Scene [202(m10)] ON

However, when I press the button on the keyfob only three of the four lights in the scen turn on. The command that both events triggers is exactly the same, yet in one case all four lights come on and in the other case only three lights come on.

To further debug the situation I then setup another button on the same keypad that has the button that worked and setup a rule to execute the same command as above upon keypress. A press of the second button exhibits the same behavior as when the keyfob is pressed (only three of the four lights turn on).

This behavior is very consistent. I have tested each of the scenarios dozens of times so it's not just some intermittent line noise....it works the same every time.

I am stumped. any help would be appreciated.
Try this to see if there is some timing issue:

Instead of turning ON the scene, activate an unused output, say output 100 for 2 seconds.

When output 100 turns OFF THEN activate the scene. This will add 2 seconds of delay between pressing the button and the lights turning ON. If this works, then there is some timing interference between the W800 and the lighting devices.

Feed back the results and we will go from there.
I feel REALLY stupid.....I forgot that a while back I had created an Insteon link from the keypad button to the light that was not going on when I activated the scene. That's why it worked from the one button and not the keyfob or other keypad button.