• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

ELK-M1EXP Not Working - Any Suggestions?

SpaceCowboy

Active Member
Just trying to install my M1EXP but can't seem to get it to work. It won't connect to the ethernet network although I get a link light. The system goes through a boot but never gets a DHCP address or am I able to communicate with it on 192.168.0.251. I don't think the green light is flashing enough on the Digi ethernet module.

I've tried a few different patch cords and a coupel different switch ports.

Anything else I can try/check before sending it back to AutomatedOutlet as a DOA module?

Thanks!
 

Steve

Senior Member
SpaceCowboy,

Did you look at THIS thread?

How is it hooked up? Can you 'Find' it in RP? Hook your laptop directly to the XEP with a crossover cable for the most accurate test.

If you still have trouble, please post your exact configuration and steps you have taken.
 

SpaceCowboy

Active Member
I have a small 4 port switch. So the ethernet port is plugged into the switch and my computer with the ElKRP software is also plugged into the same switch. When I boot the M1XEP, I'm unable to ping it (according to my DHCP server nothing has asked for an address).

So I'm thinking there's something wrong with the ethernet port on the M1XEP as it shows a link but you can't ping it. There's no router or firewall between my PC and the M1XEP.

I tried connecting the M1XEP with a crossover cable to my PC and it still won't work (I didn't need to readdress my PC since it was already on the 192.168.0.x network).

I think I'll have to send it back.

Thanks for the advice though!
 

Spanky

Senior Member
Make sure the upper 3 octets of the IP address of the PC are set the same as the upper three octets on the M1XEP.

Example: PC should be set to 192.168.0. XXX for the FIND routine to find the M1XEP.
 

toymaster458

Active Member
I had my M1EXP working at once upon a time and after taking the system on a couple of demos I can no longer access the M1EXP. I have tried accessing it from the default IP having my system set to 192.168.0.1, tried the last known IP, did a search all with no luck. Is there a way to set the M1EXP back to factory defaults?
 

Spanky

Senior Member
The latest version of the XEP has a two pin jumper, JP2, next to the metal can on the PCB. With this jumper ELK Technical Support can instruct you on how to default the XEP to a known IP address.


Call ELK technical support. 800-797-9355.


Next release XEP software upgrade is in Beta testing and will give many nice enhancements. This will include an ELKRP upgrade also. Should release after the first of the year.
 

toymaster458

Active Member
Well I finialy got it working.

I tried upgrading the firmware on the M1 and that made no difference but I then tried the search feature from RP again with out the unit hooked up to the M1 and I was able to find it. After that I was able to hook it up and all is working. In the past I had an issue accessing the JAVA. It would not come up all the way and kept locking. Now everything works like a dream.
 

Spanky

Senior Member
Here is come additional information from the M1XEP Guru on the M1XEP and how it can be setup. This works with the latest versions of the M1XEP.

JP2 jumper now allows you to default the unit to DHCP or Static (192.168.0.251). Power up with the jumper in place and wait for the green LED on the RJ-45 connector to blink one or two times over and over. 1 blink = DHCP, 2 blinks = Static (192.168.0.251). If it is not blinking the setting you want, power it down and back up again – it will default to the other setting. When it is blinking how you want, remove the short on JP2 to let it continue to boot up.

Do not change DNS2 settings until the next ELKRP release.
 

WayneW

Senior Member
David, My XEP works fine on DHCP, but I would like to change it to static. When I use J2 to change it to double blink, ElkRP cannot find it. When I change it back to single blink, it works fine.
 

Spanky

Senior Member
It is setting the static address to 192.168.0.251. You computer's upper three octets (192.168.0) must be set to the same values for ELKRP to find it. Change your computer IP settings, find the XEP, change to a static IP you like, then change the computer back to its origonal IP value.

If this does not work, call Tech service Tuesday at ELK.


Happy new year!!
 

electron

Administrator
Staff member
Keep in mind that you can not configure the 2nd DNS server, or it won't take the changes. Let me know if you need help.
 
Top