Elk M1G Two-way Wireless - going mad?

MarkH056

Member
I have a crazy situation that I can't explain. I'm hoping someone here can confirm that I'm not going mad. 
 
I purchased an Elk 6022 wireless sensor along with some wired garage door sensors to wire to the 6022. The 6022 has one magnetic reed switch, but also two wired ports for external sensors (the wires to the sensors must be very short). I installed the garage door sensors and wired them to the Elk-6022.  So far all is going according to plan.
 
In the Elk RP software, wireless zone 17 was already defined, as I have one other wireless sensor.  I added zone 18 and 19 as the Elk 6022 using the appropriate TX-ID and Loop number for the appropriate zone. The garage double-door on loop 1 and the single car door on loop 3.
 
Once done, zone 18 for the single car door (which ended up being TX-ID loop 3) was working perfectly, but zone 19 (TX-ID loop 1) would not read at all.  We primarily use the double-car door. I could see the 6022 transmit the door opening because the 6022 has a status light, but nothing was received by the Elk system. 
 
I read in the 6022 instructions that it is recommended, but not required, that the devices be defined in sequence. I had defined them backwards, first was loop 3 then loop 1.  So I deleted zone 18 - set all the parameters back to null/blank. I proceed to define zone 20 as TX-ID loop 3.  So now, zone 19 is loop 1 and zone 20 is loop 3 - in sequence.  After completing this, zone 19 is now working perfectly, but zone 20 is not. 
 
No wiring was changed, and zone 19 definition was not changed. 
 
Am I going mad? Why would this work this way? How can I get it to read both loop numbers?  I just can't figure it out. It's as if the M1G is ignoring the loop ID entirely. It finds the first zone that matches the TX-ID, and that's what it matches on. 
 
Thanks for the help!
 
Mark

p.s. I forgot to mention that I have the ELK-M1XRFTW (not the newer rftwM) and the distance between the 6022 and the XRFTW is approx 20 feet through a wall (an attached garage). 
 

mikefamig

Senior Member
I have never installed a 6022 but I'm thinking that maybe you need to assign the internal reed switch before assigning the two remote switches. I would give it a try.
 
Mike.
 

upstatemike

Senior Member
I don't know if this matters and I have never used one of these but I did notice in the directions that the magnetic reed switch is considered the second sensor of the three. Are you sure the third sensor position, which is the second external sensor, is getting enrolled?
 

MarkH056

Member
I'm positive that the third sensor position (loop 3) is enrolled. That sensor was working perfectly when Loop 3 was a lower number zone than Loop 1. But, in that configuration, Loop 1 (Zone 19) wasnt being recognized. When I moved Loop 3 from zone 18 to 20 in software only - no changes to wiring - then Loop 1 started working and Loop 3 is not. 
 
Its now been 48 hours and I've got a loss of supervision warning for Loop 3. 
 
I manually entered all the wireless using ElkRP. I didnt use the keypad enrollment process. If I could figure out where to post the screen image online somewhere, I would link to it here so you could see the wireless settings. 
 

RAL

Senior Member
MarkH056 said:
Do I need to upgrade the firmware of the M1G panel? Or the XRFWM? 
It's certainly worth making sure you are running the latest firmware levels, though I'm not aware of any fixes for the problem you describe.  But that doesn't mean there wasn't one.
 
The most recent level for the M1 is 5.3.10
The most recent level for the M1XRFTW is 1.2.56
 

MarkH056

Member
I have never upgraded the firmware of the M1G, and I installed it nearly 10 years ago. I suppose it's worth a shot. . . M1G is running 5.2.8 but the XRFTW is current on firmware. 
 

MarkH056

Member
So, closing this thread out. I did upgrade the firmware of the M1G pane and both zones are now working. Either the firmware upgrade, or the subsequent reboot of the M1G, has solved the issue. Thanks for everyone's advice!
 

RAL

Senior Member
Glad you got it working!  And thanks for letting us know.  It helps others down the road to know what worked and what didn't.
 
Top