• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

Elk M1XEP Internet Connection

Len12121

Member
Hopefully someone can help. I can access the elk virtual keypad through local network. So physical connections seem ok. I cannot get through from a remote location using the internet.

I have a Linksys wrg54gs router and cannot seem to get through it.
I have port forwarded ports 2601,80 and 26 with no luck.
I have a dhcp address . Should this work. Any help appreciated.
 

Len12121

Member
Thanks for the quick reply.
I get no login screen.

Cox says they do not block these ports.
Login works normal through local network.
 

electron

Administrator
Staff member
Chris_RM works for Elk, so check out this thread, if you haven't already:

http://www.cocoontech.com/index.php?showtopic=3919

But it looks like you are already forwarding those ports, so it should work. I am not sure if I would forward the ElkRP port (for security reasons).

Also, Cox is known to block port 80, so try the work around suggested in the thread mentioned above.
 

Len12121

Member
Thanks again.
The instructions do not say exactly how to forward one port to another.
How do you actually do this?
 

Len12121

Member
Sorry for the confusion.
I have done port forwarding but in Chris_RM he says to avoid cox blocking port 80 to use another port say 2110 and to forward that port to port 80 in the router so that the elk can see port 80. I am not sure how to forward port 2110 to port 80 in the router.
Hope I am clearer.
Thanks.
 

electron

Administrator
Staff member
Ah ok. Not all routers allow you to pick a different source/destination port. If your port forward setup screens looks like the one in the link I pasted, then you probably are out of luck (unless this can be changed on the M1XEP).
 

torgrimj

Member
I am able to get to the point where I put in my username and code. It then launched the java applet, and the it comes back with Device Busy, another device maybe connected. I am not sure what the problem is, any advice?

Thanks

JT
 

wbonnell

Member
I am having a similar problem trying to connect from outside network. I have all ports forwarded. I get to the login screen and then I enter my login and password and hit enter. No java ever starts loading and page will not connect. Any help would greatly be appreciated!!

Bill
 

IVB

Senior Member
Can you access it from inside the network? On the same machine?

My immediate thought is that if java never starts loading, you may have the security cranked up too high on that machine. Try adding that URL to your "trusted sites" section, see if that does anything.
 

Digger

Senior Member
Len,

I have the same router and the same problem. Lately I can no longer get the ELK-RM to work either from within the house but RP works fine. Very strange.

Most likely we are overlooking the obvious. I will try and work on the problem some more this week and post any findings. More than likely someone will provide an idea that will allow us to find the problem.

I know Chris at ELK and he is a great guy. I am sure if you call him again he will do everythinig he can to help you. I am just never free during the day to call him when he is at work.
 

wbonnell

Member
IVB

Yes I can connect from inside. I tried adding the IP to trusted site with low security and still doesnt work.

Bill
 

Digger

Senior Member
Same here the insdie works and the outside does not. Tried to open the port for the unsecure and it still did not work.

I will try some more in a few days.
 

wbonnell

Member
Anybody have any ideas?? It seems like maybe something is wrong when java tries to load - I never see any sign of java loading!!

Thanks
Bill
 
Top