• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

ELK M1XEP will not connect and keypad will not allow programming

CZIflyer

New Member
I am just setting up my M1G with the M1XEP.  I set it up temporally and got the keypad enrolled and the M1XEP online through the RP software. 
 
I then modified the closet and re hooked up the M1G and now having problems. 
 
I think the keypad is not enrolled and it will not allow me to enter the program mode.  I select the ELK button, press 9 for program, and it asks for the pin authorization code.  I enter 172839, and it doesn't do anything and eventually will go back to the main screen.  The screen reads Not Ready Area 1, Output 2 trouble ( no siren connected yet)  Ethernet trouble, and common not armed
 
Question:  Can I re enroll the keypad?  Do I also need termination jumper on back of keypad and M1G J3 if I only have one keypad?  I have tried it both ways
 
And to really complicate matters I can't get the M1XEP on line.  I have static address of 192.168.0.251. and opened the router port 2601.   I ran the diagnostic and this is what it came up with:
 
Name:
MAC Addr: 00-40-9D-B6-60-24
IP Addr: 192.168.0.251
Secure Port: 2601
M1XEP serial port OK: No
M1XEP has initialized: No
DHCP: No
Subnet: 255.255.255.0
Gateway: 192.168.0.1
Pri DNS: 0.0.0.0
Sec DNS: 0.0.0.0
Non-secure Port: 0
AMX Beacon: No
Email Server:  (IP)
Email Port:  25
Email From Addr:
Email Username:
Email POP before SMTP: No
DDNS Server:  (IP)
DDNS Username:
DDNS Hostname:
DDNS Email To:
DDNS Email on Change: No
SNTP Server:  (IP)
SNTP Update Time: 00:00
SNTP Time Zone: GMT-13.00
SNTP Email on Errors: No
Bootware Version: 2.0.4
Application Version: 2.0.42
 
Problems:
There may be a problem with serial communication between the M1XEP and the control.  Check the serial cable connections and the control's serial port baud rate.  This error can also occur if the M1XEP's firmware is older than version 1.3.24.
 
The M1XEP did not properly synchronize with the control.  It could be still initializing.  Wait several seconds, then click the BACK button and try again.  If that doesn't help, reboot the M1XEP and try this again.  If the problem persists, check the serial cable connections and the control's serial port baud rate.
 
The M1XEP's Primary DNS is invalid.  That may prevent the M1XEP from making out-going connections.
 
 
 
Results of the test of DNS address
 
00:02:37 DHCPINFORM enter
00:02:37 DHCPINFORM sock=00000028
00:02:37 Open_Socks: 12 = 01
00:02:37 DHCPINFORM sendto returned: 00000100
00:02:39 DHCPINFORM recvfrom returned: FFFFFFFF, RcvTimer=0
00:02:39 DHCPINFORM getErrno returned: 00000000
00:02:39 Close_Socks: 12 = 00
00:02:39 DHCPINFORM done
00:02:39 DHCPINFORM ReturnCode=02
 
 
Could this be one of the problems?
M1XEP serial port OK: No
M1XEP has initialized: No
( I changed the ethernet cable, but don't have a replacement ribbon cable)  Also I tried to reboot the M1XEP using the diagnostic.
 
Thanks for your help
 

RAL

Senior Member
The M1 will enroll the keypad with address 1 automatically.  You don't need to enroll it manually. Since you are getting messages on the screen, it sounds to me that it is enrolled ok.
 
Do you have just the one keypad on the data bus?  Any other input or output expanders? 
 
You need to always have 2 termination jumpers on the data bus.  If all you have connected is the one keypad, then there should be a termination jumper on the M1, and one on the keypad.
 
I'm not sure why you're having trouble entering the installer code. If you don't have the termination right, that could certainly cause trouble.  Or a bad data bus connection on either end could cause problems.
 
For the M1XEP, since it appears there is a serial port problem, check the pins on the serial cable on both ends to make sure there isn't a bent pin somewhere.   Also check the serial port baud rate and other settings.  But you'll need to get the keypad working for that. 
 
One other thing to try is connecting a PC directly to the serial port (without the XEP) to see if you can get access to the M1 that way.
 

TrojanHorse

Active Member
I’m not sure exactly what your problem is and it appears you’ve tried to troubleshoot. You may know more than me.

That said, to help it’s worth confirming that your XEP communicates with your router and LAN. You mentioned “static IP” setting. I’ve often seen it recommended that this goal is best achieved using DHCP reservations on the router. Did you do that? No need then to set a static IP on the XEP config.



Sent from my iPhone using Tapatalk
 
Top