ELK-MIKP Keypad enrollment error


I am installing a M1Gold system and have the hardest time getting my keypads to work – any help in figuring out what is wrong is greatly appreciated.
I have a M1 Gold main board and a M1 Database Hub with 3 ELK-MIKP Keypads and 4 M1 Zone Expander boards ELK-M1XIN, I installed the 3 Keypads on the M1-DBH and put the termination plug into the first empty slot and also inserted the jumper JP3 on the M1 board. Then I went ahead and programmed 2nd Keypad to Address 2, the 3rd to address 3 but it always losses connection once I change the keypad address and I am unable to enroll them to the bus. Also tried enrolling them via the ELKRP software (setup all the areas and keypads and send them to the system) but it does not find them, so I can not enroll them this way also. To trouble shoot I went ahead and started disconnecting everything from the M1 and attach Keypad one directly to the databus – it works fine until I try to set a different address – which always brings up – Lost conn. And I am stuck there and unable to enroll. I measured my Ohms – turned off the board shows 64 Ohms, measuring when it is powered it flux’s from the 20s up to 160 Ohms. Installed on the M1-DBH it shows 148 Ohms with JP3 terminated and 3 Keypads plugged in – plus the termination plug on the data bus hub board (No termination at the keypads according to the manual for use with M1-DHB). This seemed to high and according to my research so far it should be between 50-70 Ohms…what am I missing??? I tried all day, went through the manuals about a 100 times and at a loss :ph34r: . Somebody please enlighten me! Thanks.
First thing to do is get the keypads working. Attach all three keypads directly to the M1 using very short cables like no more than 2 feet. Have a termination jumper on the M1 and on one of the keypads. Verify that you have keypad addresses set to 1, 2, and 3. Use installer programming menu 1 and enroll the system. It should show 3 devices enrolled.

If this works, start moving the keypads to the DBH one by one until you find the failure. Then troubleshoot!!!

Make sure you do not have the Data A and Data B crossed somewhere.
It was a damaged cat5 cable to keypad one-replaced this and it worked like a charm. Lesson learned – always check your wiring before you hook-up anything and put that Ohm meter to use. Thanks for the help...