• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

Elk RP Keypad Status

BraveSirRobbin

Moderator
I'm using the Elk M1 Gold with latest firmware and updates:

Hardware Version 0.10
Boot Version 3.1.13
Firmware Version 4.3.10

And only have one keypad connected (as of now) with latest firmware and updates:

Firmware 2.1.40
Hardware 0.7
Bootware 3.0.4

I am running the latest version of the Elk RP software (1.6.6)

I can connect to the Elk M1 Gold fine, downloaded all so "no conflicts" exist. When I go to the "Status" menu to view the realtime zone status the display will only let me show the last seven zones (10 thru 16). When I try to scroll up it will not let the first nine zones display.

What am I doing wrong? I tried uninstalling and reinstalling the Elk RP software, reflashed the firmware in the Elk Control unit and keypad.
 

Attachments

  • error.jpg
    error.jpg
    84.8 KB · Views: 40

Digger

Senior Member
I beleive its a bug they are working on...... theres also another thread somewhere with a workaround.
 

Captain Caveman

Active Member
BraveSirRobbin said:
When I go to the "Status" menu to view the realtime zone status the display will only let me show the last seven zones (10 thru 16). When I try to scroll up it will not let the first nine zones display.
Ya, I have the same problem. :)
 

Spanky

Senior Member
ELKRP has an issue. Make one of the columns narrower in the status display form. It should work then. The form is 1 pixel too wide and ELKRP is going to the bottom of the list. It is fixed in the next update.
 

BraveSirRobbin

Moderator
hmmm, OK, Spanky's fix worked. Don't EVEN want to tell you how much time I spent on this trying to fix it (thought it was a firmware or software problem I did :) ).

Before I spend more time on this unit how about this one. Every time I connect to the Elk via RP I get a notice that my wireless setup is in conflict (between the controller and my current RP setup).

I say resolve and download conflicts, but this message still shows up every time I connect.

FYI: I have NO wireless nor ever setup any wireless devices!
 

Attachments

  • wirelesserror.jpg
    wirelesserror.jpg
    29.5 KB · Views: 40

pkoslow

Active Member
BSR,

I'm seeing the same issue with conflict on Wireless even though I don't have any installed or configured.

Have been ignoring since I'm still only bench testing the unit, but would be nice to resolve.

Thanks,
Paul
 

Spanky

Senior Member
Information from the ELKRP Guru:

1. A more permanent status screen scroll down workaround:
Right click desktop
Click on Properties
Click Appearance
Click Advanced
Click Item and select Scrollbar, change the scrollbar width from 17 to 16

2. Showing conflict in unused wireless setup.
There is an unused bit or byte in the wireless area of the M1 or ELKRP that is not defaulted.
Fix:
Create a new DEFAULT account in ELKRP which will be your new account file.
Receive all data from the M1.
Send all data to the M1.
This defaults the wireless area in both the ELKRP and M1 and the conflict should go away.
Delete the old account file when everything is OK.
 
Top