Elk Touscreen


New Member
I am new a new Elk M1 Gold owner and have not been able to get the touchscreen to talk to the main panel. When I try to connect the touchscreen to the main panel, a small window opens and it loops through the following sequence:

ElkM1 Status:
Connecting In N seconds...

ElkM1 Status:

ElkM1 Status:

(where N counts down from 10 to 1).

This happens over and over.

My system:
ELK-M1GOLD Main Panel
ELK-M1XEP Ethernet Interface
ELK-M1KPB Keypad
ELK-TS071 Touchscreen

The system is brand new and spread out over my workbench for setup. Initially, I used a laptop with Elk's USB-RS232 adapter to communicate & setup the main panel using ElkRP2 v2.0.8. That worked great. I then added the M1XEP module to the main panel, replacing the USB-RS232 cable with the M1EXP's serial cable to the main panel. Using the laptop, I configured the M1EXP to use a static IP address. Running ElkRP2 on the laptop, it is able to communicate with the main panel using the "network" communication setting. Also using ElkPR2, I enabled the non-secure port (2101), and enabled Serial Port Transmit of everything (Event Log, Task Changes, Zone Changes, Lighting Changes, Output Changes and Keyad keys). The baud rate is 115,200.

To confirm M1EXP/M1Gold connectivity, I close ElkRP2 on the laptop, open a web brower, and point the browser to the M1EXP's static address. The Java keypad application starts and I can communicate with the main panel. So I close that, and try to communicate w/ the touscreen. From the TS071, I start ElkRM and enter the M1EXP's static address and the non-secure port (2101). I have tried using the Installer Code & user codes. I every case, it does the above sequence ending immediately in "disconnected".

I know the touchscreen is connected to the network w/ proper gateway, mask, etc because I can use the touchscreen's web browser, and, after setting the Zip Code and clicking "weather", ElkRM displays correct weather info (yes, MORE snow). Incidentially, I downloaded a trial version of ElkRMS onto the laptop, and the exact same thing happens.

Any ideas on a setting that I am missing?

Some versions from the laptop's RP2 help screen:
Main Program Version 2.0.8
M1G Control Version
M1 Control Version
EZ8 Control Version
ElkComm Version 2, 0, 0, 0
ConvertDB Version
ElkSafe Version
ErrorDlg Version

On the touchscreen, ElkRMS ver. 2.0.10
hi McA, welcome to CocoonTech!

Can you ping the M1XEP from the ELKTS07? Or if there no ping command (it has been a few years since I have sold mine), can you access the web interface? The JAVA applet won't load , but you should at least see some sort of webserver response. The other thing to try is trying to connect to the insecure port of the ELK M1XEP using the telnet command, from the touch screen, and your PC.
If you loaded ELKRMS on a laptop and it does not connect but ELKRP does connect, the most common cause of no connection is ElkRP is still open. ELKRMS will not connect while ELKRP is connected to the control.

Report back the results.
Even if RP is open, it should still connect (but show a message that it is in installer mode or something like that), shouldn't it ? Manually setting up a telnet session is the best way to test the port. Maybe the XEP (and even the M1 itself) needs another reboot.
I know it'll do that behavior if the settings aren't all correct (port, login, etc).

I also think I recall RMS not working over a secure port? Point it to the non-secure port - and if you set any logins on the XEP you'll need to set that too I believe.

I'm sorry - working from memory here... but if you double check those things and don't get it, I'll fire up RMS and RP and take a better look around.
Thanks for the replies! It's fixed: here's how... After getting back from the office this evening, I thought I'd try your suggestions; a) make sure ElkRP was always closed before trying ElkRM, and 2) try pinging from the touchscreen.

A) I was pretty sure that I always closed RP before trying RM, but I tried again and confirmed that the problem persisted with nothing except for ElkRMS (from the laptop) and separately ElkRM (from the touchscreen) was attempting to access the M1 panel. No help, but worth confirming.

2) Ping got replies.

So the problem is fixed, but I can not fully explain it. Apparently, the subnet mask was set incorrectly on the ethernet interface module, even though it was entered correctly ( in ElkRP? After adding another user, thinking that maybe a new user will full permissions would allow ElkRM to connect, I pressed "Send/Rcv" and exchanged *all* settings between ElkRP and the panel (rather than just transmitting the user). In the process of updating all settings, ElkRP claimed that the subnet mask was different, and that changing it might cause a loss of communication with the panel and it would reboot the ethernet module. I was surprised b/c I'd set the subnet mask to "" (the correct setting) when I'd set (and later, quadruple-checked) the static IP, but clicked "okay" anyway. Somehow, when the static IP was set but the subnet mask was not? I can't explain it. Since I typed both the subnet mask and the static IP at the same time, and updated the panel with both, and the panel *did* get the correct static IP, I can't explain one setting (the IP address) being uploaded to the panel but not the other (the subnet mask) but that appears to be what happened?

Anyway, eveything works fine now! I don't know what the module thought it's netmask was, but the "TCP/IP" tab in the "M1XEP" menu still shows all of the settings as being the same as before the "Send/Rcv" but it works now.

Thanks again for everyone's time helping a newbie!!
Dan (electron)-

You say you sold your touchscreen; did you sell your entire Elk system, or did you move to something else for a touchscreen interface? If so, what (if you don't mind me asking). I am thinking that, long-term, I'd like to write a custom Android tablet app to give same functionality as TS071, but am wondering what others use?

Thanks again for the earlier reply
I went with an Atom based in-wall touch screen (would have to look up the make/model), but next time, I will just go with a wall-mounted iPad, which would be a lot cheaper. I use HSTouch (Homeseer), and ELKRMS once in a while. For Android, ElkDroid is the best native option, or use something like HSTouch/CQC for Android.
I'm very interested in a good flexible android interface geared more for the new wave of tablets on their way (I have no idea how well elk droid works)... so if you build something I'd definitely take a good look.