• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

ELKRP connection

RAKY0311

Member
I have a connection problem whit my ELKRP and M1 after suffer of power failure yesterday,when I try to connect the ELKRP a dialog show this:
"SYSTEM DID NOT RESPOND CANNOT DETECT BAUD RATE SETTING"
I try to change the serial port setting but dont see any problem,I'm using a serial port connection with M1 and newer have a problem,I check for cable broken but no found problem ,also my Homeseer-M1 plug-in work perfect and use the same cable(custom made 50' cat 5).
please I need some help here!
 

electron

Administrator
Staff member
Stupid question, but have to ask anyways, you don't have Homeseer (and the M1 plugin) running while you are trying to connect with RP, do you?
 

RAKY0311

Member
no,I know this cant' runing at the same time,but have working HS with M1 can tell me that the cable and the config port working good,what do you think?
 

Spanky

Senior Member
Check the baud rate in Globals for 115K baud. Use the keypad in installer programming mode, option 7, then find the baud rate. Also make sure the ELKRP code is correct and the serial number is correct in ELKRP for the account you are trying to connect to.
 

RAKY0311

Member
Thanks SPANKY ,I ckeck the baud in the keypad,the RP code and the serial number and all are fine,I dont' know if this means someting but my RP stop connecting after a power failure and when this happen the RP was connecting with M1,before that my sistem work superfine. "?"
 

Spanky

Senior Member
There are 3 areas that could have changed:

1. Something has changed in your serial port settings.

2. Something changed in ELKRP settings.

3.Something changed in the M1.



Elimination of the unknowns:

Make sure you have your M1 program settings backed up in ELKRP. Do a factory re-initialization of the EEPROM. Keypad installer mode, Global programming, 07, then EEProm default, 45. Enter 99. This will reset all settings back to factory default.
Using the default settings as far as the ELKRP code on ELKRP try to connect. If successful "Send All" of your program setting to the M1.


Connect Hyper Terminal to the serial port that is connected to the M1 with the proper baud rate settings. You should see data coming out of the M1 at least every minute or more often.
Send "09ct00300CD" with a carriage return to the M1. This should toggle output relay 3.


When all else fails, call Elk Tech Support 800-797-9355 for assistance.
 

RAKY0311

Member
I do the re-initialization of my panel and try to connect but the same happen,I'm very frustrated because I lost all my setting,voice announcement and task.Thanks SPANKY for help me.At least HS can communicate with M1.
 

electron

Administrator
Staff member
can you reboot the PC, but start in safe mode, then connect with hyper terminal or RP? I have a feeling that the plugin isn't releasing the COM port after exiting HS.
 

RAKY0311

Member
I run my comp in safe mode and when I try connect a dialog say "port deleted or in use by other prog",question:how I can disconnect HS from COM1?
 

Spanky

Senior Member
If HS is communicating with M1 then the serial port on the M1 is working. Need to check ELKRP's setup and make sure all other programs are not running that use serial port.
 

electron

Administrator
Staff member
RAKY0311 said:
I run my comp in safe mode and when I try connect a dialog say "port deleted or in use by other prog",question:how I can disconnect HS from COM1?
in safe mode, nothing should be using that COM port. Anyways, download Portmon (free) from Sysinternals.com, and see what process is accessing that COM port when HS is not running.

This program can monitor your com ports while they are in use, so this should do the trick. The Elk M1 sends out a message at least every 30 seconds by default, so you should see something, and it will give you the process name if there is indeed a process still accessing that COM port after HS has been exited.

Let us know if this helped, good luck!
 

jlehnert

Active Member
I'm not sure from the thread, but did you try shutting down HS and then connecting ELKRP using the cable/port formally used by HS?

As for the power outage, you could have fried your serial port(s) on the computer. My OmniPro has two serial ports in it, one hooked up to HS on one computer, and the other hooked up to the HAI programming software on a different computer. When I lost communication on both computers, I figured "it's got to be the Omni, since both computers can't connect". WRONG! After sending the alarm down to New Orleans for a checkup (this happened a year ago) and it coming back with "no problem found", I investigated the com ports on the PCs. Sure enough, the serial boards on the Omni were good, but the ports on BOTH PCs were blown. I got eveything running again, and then the same thing happened 10 days later. Now I've got APC rs232 surge protectors on both ports coming out of the Omni.
 

RAKY0311

Member
I have only one port and I using for both HS and RP (one at time) HS work but RP not,I download RP again and installed and configured but no connection,restart M1 to default setting but nada,I check my cable 20 times,configure COMM1 40 times and the same happen HS can connect and RP not,I shut down HS and no connection.very frustrating!
 

RAKY0311

Member
yes I due,and portmon say "canot attach COMM1 because this port are in use",also now when I open RP windowXP told me that this program have to be closed for internal errors,any idea?
 
Top