• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

ELKRP Error

noshali

Active Member
Hi,

I downloaded the software and installed it. I am getting the Database error.

"Cannot find the operators database or it is not a valid ElkRP operators database. If it does exist, you will need to re-install ElkRP. Do you want to browse for it?"

I click yes and the options window opens up. The browse button does not work. I can see (using file manager) that controls and ops are in the correct folder.

I installed it on the dektop and it works fine. I compared the items in the folders on the 2 installs and the files seem to be the same. I initially got the same error on the desktop but rebooting it helped.

Laptop keeps on giving me the error. Even after numerous installs and removes. I see the mdb file in the ELKRP folder.

1. What can I do to fix this????
2. Do I need access installed on my laptop??

regards,
 

noshali

Active Member
No...I want to use the laptop as it wold be easy to carry it to the basement and then disconnect once al is setup on the panel.

I am starting fresh. Downloaded the software yesterday and never used it before.

Regards,
 

AutomatedOutlet

Senior Member
OK, is the panel installed and have you ever connected any computer to it? If so, you should be able to load the RP, create and account with the panel serial number, and connect. Once you connect, download the panel programming into RP.
 

noshali

Active Member
Martin,

The panel is up. I have not connected the pc yet. I can't get past the software install. The software does not install and gives me the orrors that I have specified. Works fine on the desktop but carrying the desktop with the monitor is not feasible.

regards,
 

AutomatedOutlet

Senior Member
Did you get a CD of the RP software when you bought your panel? If so, I would try that. Otherwise, I'd re-download the software and try a new install. Perhaps Spanky can give you a better answer.
 

Steve

Senior Member
noshali,

This is from Elk Support. Most likely it is a problem with some of the file registrations.
Prob:   When ElkRP is started, the following error message appears:

"Cannot find the operators database or it is not a valid ElkRP Operators database. If it does not exist, you will need to re-install ElkRP. Do you want to browse for it?"

Sol:      Missing/corrupt database drivers:
            Backup ElkAccts.mdb if it contains any important accounts.
            Re-install ElkRP from the original source (whether from the Web,
            CD, or downloaded single EXE.)*
            When the setup program is run, it gives three options:
                        Modify, Repair, and Uninstall
            Choose Repair.
            If that doesn't fix it, choose Modify and make sure ALL options
            are checked (Core, Database, and Help)
            Restore ElkAccts.mdb if it was backed up.

Sol:      Required DLLs were not registered:
            Save the attached batch file, rename it to rpreg.bat, and run it by
            Double-clicking it.

Sol:      Bad ElkRP installation (likely from a web install)
            Backup ElkAccts.mdb if it contains any important accounts.
            Uninstall ElkRP using Control Panel -> Add/Remove Programs.
                        ElkRP v1.4.0 was titled "Elk Remote Programming"
                        ElkRP v1.4.1 and later was titles "ElkRP"
                        Remove BOTH of these if they exist.
                        Delete the C:\Program Files\ElkRP folder
            Re-install ElkRP from a different source (preferably from a CD or
            single EXE.)*
            Restore ElkAccts.mdb if it was backed up.

You can get the batch file here. This should work for you. Good luck.
 

noshali

Active Member
Does not work for me. I tried all 3 options.

What else could it be? I have admin rights to the machine but have a call in to make sure that I do. Could this be a reason.

Regards,
 

Steve

Senior Member
Wow, that's weird. What O/S are you running - XP? If you didn't have admin rights could be a reason, but with admin rights should work fine. Only other thing I could suggest is to de-install RP and remove all the files and try it again - including the above. If that doesn't work then maybe Elk has a better solution, but I have to believe its something on your laptop.
 

noshali

Active Member
Yes. It is XP. It is weird as I tried installing it on my home PC using the same file and it works.

So let's see if spanky has anything to add to this one.

regards,
 

Spanky

Senior Member
Move all the contents of the Program files\ELKRP directory to some other directory for backup. With an empty ELKRP dirctory, reinstall the new ELKRP.

Make sure you have the Ops.mdb file which is the operator data base after installing.


You may want to do the Full Install (50 meg) instead of the update install (8 meg).

The installation updates the data bases when updating the software. Sounds like the data base did not get updated properly.
 

noshali

Active Member
Spanky,

This is what I did:
1. Downloaded the full install as I did not have a CD and I have not used the software before.

2. Unistalled previous installs and then deleted the elkrp folder. No worries about backup as have never used the program or connected to the main panel.

3. I installed from the c drive (rebooted) and got the same error. So ran the batch file and it said that all drivers are registered (rebooted).

4. Checked the folder ELRP and it has the ops.mdb file.

5. Double clicked to start the app and got the same error.

regards,
 
Top