Help--"Rejected remote programming access code"


Active Member
I had to uninstall and reinstall the Elk RP software on my computer and am now unable to connect with my M1. I've tried using both the serial port and the M1XEP to communicate with the panel, but I keep getting an error "System rejected remote programming access code." This is using the factory default RP code 246801. Yes, the serial number is entered correctly with the 0000 in front.

I tried resetting the M1 to the factory defaults at the keypad, which it seemed to do, but still the 246801 RP code is rejected.

Does resetting the panel to the factory default config restore its RP access code to the default too? There's a chance that I changed the RP code initially and don't remember it.

Any other thoughts on how to restore my connection?
Let me answer my own question. For the moment, I am an incredibly lucky moron. It turns out that I was trying to connect to the M1 with the default code but had incidentally changed it at the first connection to something that I would have never remembered.

Restoring the M1 to factory defaults did not reset the RP access code to default. When I first got my panel, I must have been so anxious to get it up and running that I didn't pay attention to entering the factory default RP code and picked some insignificant number instead.

Fortunately, when I uninstalled and reinstalled the ElkRP software, a backup database file was created. I was able to direct ElkRP to this back up database file and view my old RP access code from the old account.

What would have happened if I could not have recovered my old RP access code?
Don't loose your ELKRP Access Code. The Access Code and Serial Number is your security to keep others out of your M1.

Defaulting the M1 does not clear the access code.

To recover the ELKRP access code is not a pretty sight!!! :)
Spanky said:
To recover the ELKRP access code is not a pretty sight!!! :)
I never did figure out what happened, but mine got lost. Anyway, I had to send the panel to Elk and they reset it back to default for me.

Is it possible to change the RP code once it has been set? I can't find this in the program.