Homeseer Event Question


Senior Member
This week I got to feeling guilty that I paid for Homeseer and wasn't using it so I fired it up again. (version 1.7.44 with VWS and JDS plugins). I created some events to load weather data from my RainWise into my Stargate and that works fine.

I also created a test event that fires off a batch file whenever a specific X-10 address changes state. This also works fine UNLESS I stop Homeseer and restart it again. Then the batch file stops working. If I look at the log it shows the X-10 trigger firing successfully but nothing happens.

I can fix it by going into the event to where the application path is specified and even though the path is there correctly, I browse to the same location and hit OK to specify it again. After this the event works fine until the next time I stop and restart Homeseer. Anybody know what I'm doing wrong?
Wow, with all the folks on this board who use Homeseer I'm surprised nobody has any ideas about this problem!
Can you show the value for the application path field? I am wondering if you have any spaces or other strange characters in the path.
This is what is in the application path field:


Just fired up Homeseer and it is NOT working but I get the following entries in the log when I try to trigger it:

J3 (JDS Side Lamps) J Off
Status change trigger (SG Trigger):JDS Side Lamps J3 Off

So I know the trigger is working.


Just went into the event, browsed to the exact same application path, hit OK, and now it works. It will now work until the next time I stop and restart Homeseer.
Can you try notepad or something, just to see if it has a problem with locations which aren't in the system path.
I just added C:\StarGate to the path then stopped homeseer and started it again. The batch file is not working.

(I'm starting to remember why I gave up on Homeseer in the first place)
Since this batch file was just one line calling an exe file followed by a bunch of parameters, I tried calling the executable directly in in the Homeseer event and put the parameters on the parameter line.

This works and continues to work after Homeseer is stopped and restarted. Maybe Homeseer has problems with batch files? Unfortunately not all of my batch files are simple one liners so I can't depend on this approach for everything. I suppose I can look for some sort of batch file compiler so I can turn them into exe files but I don't think that is the best option.
USM, I believe that I use that same method and don't have a problem with it.

Maybe try running a script with the .exe in it?
try .cmd as the extension, maybe it has a problem with trying to figure out how to execute the .bat file (which would be hard to believe). I would also try 'cmd /k C:\StarGate\xpltest.bat'.