[How-To] Configure DCOM for use with Homeseer


Staff member
How to configure DCOM for use with Homeseer
by electron

Start the DCOM configuration software by going to Start > Run and enter dcomcnfg.exe as the file to open.


Select the Homeseer.ClsString object (on some machines, this object might be called Homeseer.Application and click Properties.


Nothing has to be changed here.


Only check Run application on this computer, uncheck the others.


Select Custom Access Permissions, click the Edit button and allow Everyone access (if you wish to use IIS, also add the IUSR_machinename and IWAM_machinename user accounts) as shown in the screenshot below, use default launch and configuration permissions.


Select The interactive user only.


Use the default settings.
Could you write another how-to demonstarting a practical situation where you could use the DCOM. I have heard the term DCOM a few other time but never really paid attention to what is is capable of doing.

What is the DCOM for?
I am in the middle of writing a tutorial on how to use apache/php with Homeseer, DCOM allows you to control the Homeseer application (or retrieve information), so stay tuned!
Squintz -

Not sure what part you're questioning so I'll answer both. Hope it's what you
were asking.

Simple answer is that DCOMCNFG is used to configure DCOM dven if you are working locally, i.e. not using the D(istributed) part of COM.

Now, as far as what COM is used for with HS....
COM is a Microsoft technology that, simply put, allows objects to communicate with each other.

A typical usage is to create dynamic web pages using ASP which reference HS via COM to call various methods to either get info or issue commands. You can then create your own web pages to control/status all of the HS functionality.

I just tried installing the latest version of Apache2.0.54 and PHP5.X for the first time. I am Running a windows xp pro machine and when I went to configure the DCOM by following this How-To I was suprised to find that it did not look the same.

Using my best judgement I was able to find HomeSeer.clsString and was able to work my way through the How-To.

I created a Page to test and make sure PHP and Homeseer were interfacing with each other.

 $hs = new COM("HomeSeer.clsString");
 $hs->WriteLog("PHP","This is a test");

The above code causes HomeSeer to popup a dialog box saying that Homeseer is already running. Then the webpage generates a PHP error. (Sorry im at work and dont have the exact error on hand) But it had something to do with the fact that it was not able to perform WriteLog on line 3

So by recomendation of electron i change clsString to Application and ran the script. I got the same Homeseer is already running dialog but this time the page did not generate an error. Not only did it not generate and error but it also did not make an entry in the homeseer log as expected. This makes me think that HomeSeer.Application does exist on my computer and I am just not looking in the right place to be able to set it up.

Does anyone have an opinion about what might be happening?
That didnt do the trick...

Here is the error i get with the clsString:
Fatal error: Call to undefined method com::WriteLog() in C:\Program Files\xxxx\xxx\test.php on line 3
In the hope that this may save somebody a few hours work...
I have just migrated my HomeSeer system to Windows 7 64-bit. I had discovered this very helpful article a long time ago when I needed to access HomeSeer from my website, developed in PHP. Luckily I had bookmarked it and I remembered this adjustment to permissions was necessary.
Imagine my distress when homeseer.clsString was missing from the list of DCOM classes! After many frustrating hours wasted, I finally found this solution:
In a command window change directory to c:\Windows\SysWOW64 then run mmc comexp.msc /32
Voila! Homeseer now appears in the list (as do other 32-bit components) and the permissions can be changed as described!
More information on MSDN - search for dcomcnfg.exe and 64-bit applications.
Wow, that's one heck of a first post, thank you for sharing this info!
Welcome to CocoonTech!
Four years later...
Has anyone been able to update this procedure for Homeseer HS3 and windows 10?
Things go well until I get to: Homeseer.cls string properties -- Location:  "Run Application on this computer" is greyed.  
And in vb.net, when I try to create an object: "Dim HS = CreateObject("Homeseer.Application", "MyComputer")", I am informed: "Cannot create ActiveX component."
This used to work with HS2 and Windows 7.  (not sure if it worked with HS3 and Windows 7).