• You've been granted Beta access to this site, allowing you to explore some of the new features while they're still under construction. More information can be found in the Beta forum.

Humidity/Temp not giving any readings

cdpuk

Member
Hi,

Recently I purchased a number of parts from hobby boards and I have been very pleased so far, except for a problem I'm now having with the temp/humidity board I bought.

Last night the software I'm using (oww) crashed randomly with no specific error message. I restarted it and found no readings were coming from my devices. After a bit of investigation, testing individual devices I found the temperature/humidity board to be at fault.

When it is plugged in with the other devices I can't get any readings from any sensors. Remove the board from the circuit and everything is fine again. According to oww there's no short circuit so that's probably nothing to do with it. But still the problem must be on the board itself. I've tried connecting it alone using both RJ45 jacks and the screw terminals. All produce the same problem.

Any ideas why this is happening?

Thanks
-Chris
http://weather.cdpuk.net
 

cdpuk

Member
It's worked fine up to that point, that's why I don't understand why it just stopped. My graphs just have it dropping off now.

20060123-th-daily.png
 

ericvic

Active Member
That is really strange.

Have you had any storms around there lately? It sounds like something shorted out and is taking down the 1-Wire network when it is connected but I have never seen a 1-Wire chip fail shorted unless there was some outside influence (like lightning or something similar).

Eric
 

cdpuk

Member
No storms at all around here recently, in fact we hardly ever get storms here - that's why I never bought a lightning detector! Nothing special here at all except it being very cold.

I find it strange how everything else is fine if it was an external influence. How could it be shorting though? Is there any other way I can test it?
 

cdpuk

Member
Well here's an update:

It seems there was a problem with about 3 different wires I used, until finally, randomly, it started working - sort of...

For about 24 hours it reported humidity (looked correct) but no temperature. At 12:30 today, when nobody was about to mess with it, and the conditions outside were stable the humidity dropped to zero. First just a few readings showed zero, then more and more, until they all did (This happened over about 20 minutes).

I finally got some time now to test it in OneWireViewer on an XP laptop. It shows the USB adapter, and a DS2438. I don't know what this chip is meant to do, but I can view temperature and humidity graphs from it.

The temperature graph looks like it's giving realistic values - goes up when I touch the temp sensor and down when I walk outside where it's about 0.5 celcius according to other sensors. When indoors the humidity reads about 10%, this rises to about 75% if i breathe on it. When I walk outside again the sensor reads 0%. Holding the temp sensor also makes the humidity rise.

All of that means nothing to me, but I hope you can make some sense of it!

I would have expected temperature readings from a DS18S20, and humidy from something else but since the only one I see is DS2438 I have no idea what's wrong! Is this just an issue with the software detecting it wrong?

Thanks,
-Chris

EDIT: By the way - the temp/humidity board was inside at the time the readings showed zero. The temperature line on the attached graph is from another DS18S20, not the one on the board.
 

Attachments

  • th_24.png
    th_24.png
    26.2 KB · Views: 49

cdpuk

Member
UPDATE 2:

Completely randomly the humidity has begun to read correctly again. Seriously, between 1 reading and the next the humidity suddeny jumped from zero to 40-50% which seems correct for indoors values. But the temperature sensor on the board still does read.

This seems crazy to me, I really have no idea what's happening!
 

ericvic

Active Member
Chris,

The DS2438 chip is what takes the voltage reading from the humidity sensor and gets it on the 1-Wire network.

If had just the Humidity/Temp hooked up to the USB Adaptor and all you saw was the DS2438 then there is something wrong with your unit.

Can you please send it back so I can take a look at it and get it fixed for you.

Send me an email to [email protected] and I will get you the details.

Sorry for your problems.

Eric
 
Top