Active Member
I am trying to play around with Hyperterminal and WinXP. I got it to connect and I receive but I am unable to request information. Any thoughts on what I am doing wrong or did not do right?
I'm trying to do the same, using HyperTerminal but connecting via TCP/IP Winsock instead of the COM Port. I have an M1XEP that is working fine. I was wondering if I would be able to use the serial protocol via ethernet too.

I tried to connect and send a the string 0Da2100XXXX00xx via:
  • Port 80 - Connection closes automaticaly in about 3 seconds.
  • Port 21 - "Get 220 NET+ARM FTP Server 1.0 ready." and "502 Command not implemented." for every character typed (as I tried).
  • Port 26 - I get "02601" and get disconnected for every command entered.
  • Port 2601 - Connection remains open, but it seems to ignore the all commands.
  • Port 2101 - Same as 2601.
Where XXXX is my code and xx is the checksum. This string was generated using the CRC Calculator program.

Is it possible to do what I want? Am I approaching this the right way?
a2 – Arm to stay

I prefer to use it instead of using a1 (Arm to away) because there is people inside the house and using a1 would trigger a burglar alarm.
hmm, that should work, have you tried any other commands? try 06zs004D. When you telnet to 2601 (or whichever port you selected for the insecure connections), let it sit there for a few minutes. Every 30 seconds, you should see a status update.
Thank you electron. By reading your post I realized that I had not enabled my insecure port. :D
It works now.
FYI: You can use the M1SDK software instead of Hyperterminal to send, receive, and calculate the serial port ASCII commands. You can even open up a socket through the M1XEP with it.

M1SDK is a freebie!! Send me an email and I will send you a copy.