Insteon FanLinc with Keypad Scene Control


Active Member
I'll jump right to it - i think my question might be - is there a way to tweak the "Fast On" function for a scene?  As I understand it, "Fast On" turns any devices in the scene to 100%, so it's messing with my fan speeds.  I've searched and haven't been able to find a related situation or answer. 
I have installed a FanLinc (2475F v.41) in the canopy of a new ceiling fan and have a keypad (2334 v.43) in 6 button configuration.  I'm using the 4 buttons (A,B,C,D) to control the fan speed.  If it matters, I'm only controlling the fan speed, not the fan light, with the FanLinc (i have the KeypadLinc load connected directly to the fan light - the fan was wired with 14-3 wire so there is a switched hot for the light and an always-on hot for the FanLinc). 
This all works as expected whenever A,B,C, or D is pressed.  But if instead the button is "double pressed" it registers as "Fast On" and turns the fan on max speed.  This is especially annoying / problematic in say the guest room where someone might unintentionally double press D for fan off and instead get their hair blown back.  Oh, and they would still see the backlight on D saying "FAN OFF". 
What am I missing? How can I get it so that even if a keypad button is accidently pressed twice quickly that it doesn't turn the fan on full speed? 
By way of other background, I've used my ISY 994 to set up scenes as others have discussed in these forums and the buttons act like "radio buttons" so that only A,B,C or D is lit at one time.  I configured this by creating 4 scenes (LOW, MED, HIGH, OFF).  I set up the "radio button" effect through the scenes with the appropriate controller (1 per scene) and responders.  Per what appeared to be a stern warning in the ISY admin console software, I set the buttons to be mutually exclusive through the scenes, rather than the "Buttons Grouping" option.  I have the buttons configured to "Non-toggle [ON]".  
Am I missing something obvious?  Or does this require a workaround?  For several reasons, I really do NOT want to address this issue with a program in the ISY.  I'd much prefer to have this handled within the Insteon device / scene. 
Thanks in advance for any help that the members here can provide.
I know this has been sitting here for a while but any thoughts?
For those that are using a keypad to control the fanlinc speeds - how are you handling the "fan off" button to prevent a double tap from registering as "fast on" and putting the fan at full speed? I could program something in the ISY, but that seems suboptimal to me since scenes are faster and work without the ISY. I also think my program would in effect turn the fan off after it first received the "fast on" signal from the keypad. Not a big deal but I'm curious what others have done.
Sounds like you inadvertently double linked the light fast on/off to light AND fan control. Try factory resetting the Fan Linc and KeypadLinc, and going through the setup instructions from Smarthome again...