Insteon First time Installation Issues


Senior Member

I have recently had to rebuild my SYS server and figured it was a good time to add some Insteon devices to my home.

I started by downloading the Insteon Minibroker supplied by georgeinva2004. I then installed version 308 of the SDM that was included with the zip file. Started the SDM after install and saw the tray icon appear. I then copied over the .xdo file and ran the setup included with the zip file for the minibroker on port USB1. Executed SYS and added the Insteon addin.
At this point I rebooted the computer. I figured with all the changes a good clean restart should do wonders. After the reboot I started SYS and found that a new custom device type had been added called Insteon Root, with a child called X10. The X10 child has A-P children as well. In looking at the properties page for the Insteon Root I clicked on the detect property and watched the progress bar take about 5 sec to go from 0 to 100%. It failed to locate either of the 2 switch link V2's I had installed for testing.
After doing some checking, what I found was that the SDM was not working at all. There was no connection to the PLC. I had to remove the HID in windows and plug the USB cable in to the server to get the SDM to recognize the PLC. I am using the 2414U on a windows XP box.
Once I had this problem fixed I rebooted and again clicked the detect property however this time I noticed that instead of the progress bar moving from 0 to 100% in about 5 seconds, nothing happened at all. I went into services and checked the Premise Insteon Driver status.
It showed as started. I thought well I'll try a stop start just to see if that fixes the issue. I right clicked on the Premise Insteon Driver and the only option available was start. This was weird as the driver showed as started already. I went ahead and selected start service and was rewarded with service started. Hummmmm. OK back into SYS and clicked detect again. Still nothing.
Several reboots later I noticed that the SDM icon was no longer appearing in the tray. I thought well hell that's what the problem is. No wonder this isn't working. I clicked on the SDM executable and saw the icon appear for about a half second in the tray and then
disappeared. Now I stepped back and thought OMG I'll need to read the manual ARG! With release notes in hand I read through them as well as all the relevant posts on the forums here and found the one about the .Net error. Sure enough I checked my event logs and found this……

Event Type: Error
Event Source: .NET Runtime 2.0 Error Reporting
Event Category: None
Event ID: 5000
Date: 2/13/2008
Time: 11:10:53 AM
User: N/A
Computer: PREMISE
EventType clr20r3, P1 premise insteon driver service, P2, P3
45d7bedd, P4 premise insteon driver service, P5, P6 45d7bedd,
P7 b5, P8 1cf, P9 pszqoadhx1u5zahbhohghldgiy4qixhx, P10 NIL.

I also found that the SDM was running as an active process but there was no icon in the tray nor is it responding at all. I went ahead and manually deleted the SDM process, restarted SDM and woot it's working. Icon and all.
I then went into services and stopped the Insteon driver and the Premise server for good measure. Restarted the Insteon driver and the Premise Server started as well. Double checked that the SDM is still operational and opened SYS. Clicked Detect and still nothing. I now went back to event viewer and checked the logs again. Yep every time I start the Insteon driver I get the above error.
I went ahead and double checked that the port was correctly set using the instructions supplied by John George in one of the threads here. It is correctly setup on USB4. I then downloaded Device Controller by Rand Fredricksen and double checked that I was able to communicate to the two switch links. They worked fine from Device Controller. So now
I am at a loss.
In a nut shell:
Reboot computer and SDM loads into memory but no icon shows up and it is not accessible. Work around is to unload it from memory and execute the application again. If the Insteon Driver is not loaded then SDM loads correctly at startup.
Insteon Driver starts up but event view shows the above error. No idea what to do about this one. The detect property is no longer actually doing anything. (Probably because the driver is fubar'ed, but at one time worked. Maybe something in the registry? When the detect seemed to work correctly the first time I installed things it was incorrectly installed on
port USB1 not USB4)

I've read all I can find on the subject and am at a loss as to what to try now. Suggestions?


I did some more investigation into the problems I was having. I started by installing Premise on a newly built Windows XP system. Clean install of SYS, and then SDM followed by the miniborker, and the .xdo. Rebooted and this new system is acting exactly like the other.

So I went into services and set the Insteon Driver to manually start, rebooted and let everything get up and running. Then I started the driver manually. The driver forces a start of SDM, but the way it starts SDM is weird as the icon never shows up in the tray, but it shows in memory.

I then started SYS and low and behold the detect function is now working. So now to start up my Premise server I need to remember to start the Insteon services manually each and every reboot. There is a problem between SDM 308 and the current Insteon driver. I'm not
enough of a programmer to tell you more. But that's a work around.
Maybe if John George reads this he can post an updated driver that works correctly or point out how I fouled this install up again and again.


It doesn't look like you did anything wrong. The driver should start automatically just fine. The sdm should not appear in the tray. What does the event log say when you start the service automatically?

What port is reported by the driver in insteon root?

I actually use the serial plc not USB. There have been lots of stability issues with the usb version reported on the insteon forum.
!=!=!=!=!=! SOLVED PROBELEM !=!=!=!=!=!

Solution was to follow directions and load the .xdo into /schema/modules NOT /bin/devices DUH! Sorry to waste your time on that.

Just for reference with the above bone head setup:
The port listed in SDM by doing a GetPort is USB4. This is also the port I used for setup. The port listed in root is USB4. And you can get it to work if you manually start the Insteon driver after booting the computer.

I am starting to understand how things are supposed to work. At the moment I only have 7 devices on my Insteon Network.

1 PowerLinc V2 2414U
2 AccessPoint 2443
3 SwitchLinc V2 Relays 2476S
1 SwitchLinc V2 Dimmer 2476D

When I hit detect the following groups and members are automatically added under root.

Group 1 - Contains all the SwitchLinc's by address xx.xx.xx
Group 255 - Duplicate of Group 1
Group 11 – PowerLinc by address xx.xx.xx
Group 176 – Duplicate of group 11

I have the SetGroup value set at 1. Why am I getting all these groups auto generated?

Also the SwitchLinc V2 Relays are being detected as generic on / off devices. Before detection I went into the modules/Insteon/classes and created a new class called SwitchLinkV2Relay. It was a duplicate of the generic on / off device as far as its properties with the exception of the DeviceType/DefaultValue. That I set to 020A (See Event log below). So…

ClassName SwitchLinkV2Relay – Inherited Classes InsteonDevice and Insteon OnOffSwitch
DeviceType Object Static Text (Default Value 020A)
Object PowerStateToggle
Object PowerState On
Object PowerState Off

I modified DeviceMapFile.xml under the line that says everything above here is ignored with the following.

- <!-- The entries above this line are ignored. They are provided to guide you in adding your own devices -->
- <InsteonDevice>
--- In [email protected], "John M. George"

This is the event for the above device with the type listed:

Event Type: Error
Event Source: PremiseInsteon
Event Category: None
Event ID: 0
Date: 2/18/2008
Time: 8:59:26 PM
User: N/A
Computer: SIDEKICK
AddDevice - Unknown device type 020A for device: 0B.D4.02

I am never able to have the SwitchLinc Relay's discovered as anything other than generic devices. They are always listed as generic and for each one on startup I get one of these events in the Event log.

Event Type: Information
Event Source: PremiseInsteon
Event Category: None
Event ID: 0
Date: 2/18/2008
Time: 9:32:26 PM
User: N/A
Computer: SIDEKICK
LoadFromSys - Premise device type not supported by Minibroker driver

Any idea where I went wrong?

Thank you for your help sir.


That's great!!! I'm glad it's working for you.

The detected groups come right out of the PLC via the SDM. I have seen Group 255 (SDM creates this as an "all device" group), but not the others you mentioned. I don't believe SmartLabs actually clears the PLC database prior to shipping, so you might be seeing an artifact of their QA process. I usually clear the database prior to installing a new PLC to make sure it's in a known state.

Incidentally, the SetGroup property comes in pretty handy. I use it to register devices within multiple groups (i.e. family room, first floor, etc.). A "group device" is then created that can be bound to Home level devices giving simultaneous control to multiple Insteon devices.

Regarding your switchlinc relay, what version of the driver are you using? I added support for a bunch of devices in the latest build (I thought Switchlinc Relay was one of them).

The Generic Device capability was a stop-gap because SmartLabs was bringing out new products faster than I could integrate them into the driver. You really can't just add a class to the module the way you've described. The best you can do is get a "Generic device".

I just noticed the version of the Insteon driver in the files area is way out of date. I'll post the latest version when I get home tonight.

Thank you again. I look forward to an updated driver......... And support for the IRLinc wink wink.

You had mentioned that since Insteon was not as reliable as most would hope, and IR integration would not be a good idea. I would however like to keep my living room free of another remote. I have managed to put everything I need onto a Pronto and it even has
control over the one light in the family / theater room so lazy people like me don't have to get up to turn the light on and off during TV / Movie time.

I would like to replace that light switch with an Insteon switch. This would allow me to control that light during non-TV time. However to do this I need to control it from my Pronto for those times when we are watching TV.

The other application is my living room shades. I have a 30 foot ceiling in the living room and it gets morning sun. There are 3 sets of windows spaced about every 8 feet going up the walls. Each of these windows is equipped with remote IR controlled shades that I current control with the Pronto. Again if I could integrate the IRLinc then I could install an IR blaster in that room and have full control over the shades with SYS.

I have shared this with you in hopes of sparking some interest in adding IRLinc support.

As your time is valuable and this is a 0$ game I understand if you're not interested. But I've set the hook and who knows what the future will bring.