Premise Interesting Premise-Creston bridge and MCE control software

Motorola Premise


Senior Member
Check out this site: {note: no longer functional}
I haven't used any of this stuff (yet), but it might be interesting to folks in the community. It's got a Premise-Creston driver that allowed bi-directional control.

More interestingly (for me anyway), is a piece of software that allows remote control of a Windows Media Center computer. It doesn't appear that he's done the Premise "side" of this interface, but that shouldn't be too hard. It does appear that he's provided a fairly simple interface to Media Center that can be controlled by Premise.
Check it out!

Note that this guy - Charlie Kindel - is also the general manager in charge of Microsoft's new Windows Home Server product. See his blog here:

It'll be interesting to see what home-automation companies do with a true "home server" platform available. One also wonders what Microsoft might eventually be planning in this space.

You can set up a "virtual" lantronix uds-10 configured with the IP address and port number of the mediacenter. All serial commands will then get sent to that port and to the mediacenter controller.

Works great with the mediacenter and the sony xl2 200 disk dvd/cd changer.
Thanks for the link. Would this be the best way (MCE) to handle video?
I have a video server with both HD and SD content that I would like to control through Premise using one of my Tablet PCs running the automation browser. I tried a networked media player but mine is not detected in the Upnp AV module, or maybe I am just doing something wrong. I have a Buffalo Link Theater that plays HD mpeg2 video as long as the bitrate is not too high, I think I am going to try a Dlink DSM-750 when it comes out later this year.

Thanks Wayne
I'm partial to upnp, but I thought mce control would be interesting to experiment with.

The linkstation is (according to the web site) upnp compatible, so the control point "should" work. As a test, can you see if your premise server shows up as a media server to your linkstation? That would confirm that the control point is working properly.

I use the dsm 520 and pinnacle show center 1000. The dsm doesn't allow remote control of video play (but it does allow audio). The show center works flawlessly.

I would rather use a Upnp media renderer then a computer also, it takes less time to start up and It uses less power.

The Premise Server does show up on my Buffalo Link Theater and I also tried Tversity and Twonky servers and they show up on the list and also show up in Premise under the Upnp AV root.

I am hoping this next generation of networked media players are more compatible. The DLink DSM-750 is supposed to be out early Q2 so I hope to see some reviews on it soon.
I left off a thought from my last message.
I bought a Philips RC9800i remote that is supposed to work with Upnp media players and it only works with some of philips players so there are incompatibility problem among the same companies products also.
Thanks for all your Help
Would you look at your event log under Applications? You should seen entries from a source called PremiseUPnP. Do you see any entries that say something like:
Media Renderer Discovered = <some device name>
If you don't there's something funny with the LinkStation. You might want to test this with the Cidero control point ( It's a stand-alone control point that I used to validate my control point. If it doesn't see the LinkStation, there's something really funny with it.

One more thing. The LinkTheater needs version 8.32 of the firmware. There's another version of the LinkTheater called the PC-P4LWAG (adds wireless support) that should work out of the box (unless something is wrong with my driver).
I did not see anything in the event viewer for a media renderer, the server Tversity or Twonky shows up in the log. I downloaded cidero and will try to do something with it.

I have this version of the Link theater

It has both wired and wireless(802.11G) connections, I use it wired because 802.11G is too slow for High Definition. The DLink DSM-750 that is coming out uses 802.11n and can playback HD streams wirelessly.
I think the problem may be that Buffalo did not implement Upnp support correctly.
I tried Cidero with my Link Theater and TVersity, it finds Tversity right away but not the Link Theater. I read the cidero forums and found someone else that had a Buffalo Link Theater could not get it to work. I also saw someone had a IOData Avel Linkplayer that would not work, the IOData and Buffalo players are almost exactly same.
Thats ok though it still works as a decent media player.

Thanks John for all you help.
Hello John,

I did some more playing around with your Upnp AV control point,I used the Intel Upnp AV media render from Intels site. I noticed that cidero immediately found the Intel Media render and it showed up on my Premise computers Upnp AV root so I now know for sure that the problem lies in Buffalos implementation of the Upnp control on my Link Theater.

By the way that is a great plugin you wrote, I loaded up some music files and played them perfectly on a second computer under the control of Premise with a wireless tablet PC. Now I have to find a better Networked media player. Great plugin.

Thanks Wayne
Glad you like it! I learned a heck of a lot about UPnP writing it.

I also learned that Intel, for all it's prowess building hardware, has a lot to learn about software documentation. It was a major challenge reverse-engineering their SDK. However, I did learn through tinkering that their ViiV framework is actually based on UPnP. So, when ViiV starts showing up in home electronic devices, we have a chance of controlling them within Premise. In fact, my new DirectTV HR20 (after a software download) shows up in Premise as a Media Renderer. Unfortunately, it's not a full implementation so it can't be controlled (yet).
It's nice to see that Upnp has such a bright future.

I really appreciate all the hard work you have done to expand the capabilities of Premise.