Issue with RRS-Mod and 2-wire smokes


Active Member
So I was going to post on this thread since it is similar but also very old .
My issue is when i have the RRS-Mod installed and triggered via the Following Rule
And turn it off with this rule
Issue is when a smoke goes off ALL smokes sound as they should with the RRS-MOD, BUT I can not shut it off and it appear the FIRE ALARM is retriggering over and over.  Only way to stop it is to power off the ELK.
The logs on the ELK show it flipping between:
Repeating this pattern until i kill power to the ELK
I have the RRS-Mod powered via SAUX, I confirmed my EOLR is 820ohms, I confirmed that RRS-Mod switch is in the ON position for constant voltage signal (if I flip this switch to OFF it effectively disables the RRS-MOD and only the triggered smoke alarms but in this mode I can reset the smoke just fine from the panel).
Using 6- 2wta-b smokes on Zone 16 configured for 2-wire.  Zone 16 is actually connected to the IN RRS-Mod and the Smokes to the OUT of the RRS-Mod and the purple trigger on the RRS-Mod connected to relay OUT 3 that is controlled by the above Rule.  RRS-Mod power is connected to SAUX.
OUT 3 Common is connected to VAUX and N/O is connected to RRS-Mod trigger.  Should Common be connected to SAUX maybe?
It sounds like you've got it wired up correctly.  But you didn't mention the setting on JP1.  Do you have it set for 2-wire smokes? 
What do you have your zone definitions set to?  
When you do a smoke reset, do the sounders shut off for a few seconds and then start again?  I'm thinking that for some reason the smokes aren't seeing the reset correctly.  An incorrect setting of JP1 could cause that.
I found this thread that reports similar issues.  It seems the trouble report is sort of normal, as the RSS-MOD reversing causes the smokes and EOL resistor to be disconnected from the zone input.  When the EOL gets disconnected, that causes the trouble.  
One suggestion seems to be to change the zone response time to Slow Loop Response, even though the manual says it shouldn't be used for fire zones. 

If none of this works, one other possibility is to replace the RSS-MOD with a COSMOD2W. It will work with the 2WTA-B smokes, but will provide a 4-wire interface to the M1, which should help avoid these problems.

<p>Thanks for the reponse.</p>
<p>Yep I have JP1 set to 2wire, and the zone is set to FIRE ALARM with Type 2wire. &nbsp;Just last night I found that thread and was reading through it. &nbsp;I may try the Slow Loop Response however if that is the case I like your suggestion of the COSMOD2W which I had not know about.</p>
<p>This is my second home I have installed an ELK.&nbsp; First house I used 4-wire smokes because nothing existed and looked like those would have the least amount of voodoo in their operation.&nbsp; I believe now that was a proper assessment.&nbsp; Even dealing with EOL Relay 4-wire is simpler.&nbsp; This house actually had an alarm panel with low-voltage smokes already installed so while I replaced the panel with an ELK I decided to stick with the 2-wire smokes they had since the were compatible.&nbsp; I did have to &quot;fix&quot; their wiring cause they had the HEAT detectors on the same zone, luckily they use 4-wire fire wire so I just put the heats on the other 2 pair so they had their own loop and zone and corrected the EOL resistors on both loops to meet spec.</p>
<p>Now I am thinking of replacing all the smokes with 4-wire units since I could put the heats and smokes on the same zone with 4-wire and avoid this mess with 2-wire smokes.&nbsp; BUT if the&nbsp;<span style="color: rgb(40, 40, 40); font-family: helvetica, arial, sans-serif;">COSMOD2W does the trick that is much cheaper and easier so will probably go that route.</span></p>
Ok so tried the SLOW response at 800ms and that does allow me to silence the alarm but it seems to be latched still and will re-alarm.  Note if I trigger the Alarm from an F-key I do not have this issue.  Also if I take teh RRS-MOD out I do not have any issue resetting the smokes.
Think I am going to get the COSMOD2W and hope that resolves it.  2-wire smokes seemed to be a very bad hack, if the COSMOD2W does not work guess I will be replace 6 smokes for 4-wire and be done with it.
Ok so I think I have it solved.  And the solution is COSMOD2W.
Anyone with 2-wire smokes on an ELK coming to this thread, just get the COSMOD2W.
Additional benefit is now I get the maintenance signal from my i3 to the panel.
1st test using the F button to trigger the fire and it worked perfectly and disarmed as expected.
2nd test using "smoke in a can" worked differently then i expected but maybe not wrong.  The system tripped and all smokes sounded as they should, and entering code into Elk and all smokes stopped sounding and the tripped smoke kept its red LED lit as expected.  Nothing sounded while in this state, however if I RESET the smokes from the panel with in a few secs it would trip a fire alarm AGAIN like the smoke was latched.  However if I acknowledge the Fire everything shuts up and I waited about a minute or two before RESETTING and it was fine.  I suspect the smoke was still maybe in the room and re-triggering.
I'm glad the COSMOD2W solved your problems.  Knowing that it works will help others down the line. 
@hagak and @RAL,

Would either of you have a connection diagram for this setup? I've several 2-wire smokes and 2-wire CO/Smokes from System Sensor with the COSMOD2W.