Kodicom Diginet Driver Issue

fritzycat1

Member
I recently had the (dis)pleasure of moving my Kodicom card to a new motherboard with a new install of XP.

I ran into the error: "Kodicom Security Driver was not found : This software requires Kodicom Security Driver 0.9.0018 or higher."

I noticed that others on this board also experienced this issue. some were able to resolve it by using different driver combinations or driver updates. Some resolved it by moving to new hardware. I tried several different driver versions, but was unable to get diginet to start without the "driver was not found" message. The drivers always indicated they were installed and working, but diginet just wouldn't find them.

I'm not going to go through all the iterations of what I had tried, but I will share my final solution after two days of tinkering...

I noticed that if I disabled the kodicom video drivers, then re-enabled them then diginet would work.... then I found that if I rebooted the box, I would get the same error, and need to repeat the disable/re-enable procedure. I just couldn't get the update to stick, and I couldn't find anything that was different in the configuration after the reboot - everything looked the same as it was before the reboot.

Then I found a microsoft utility that allows command-line control of driver installations and enablement: DevCon

Using the devcon executable, I created a batch process that would disable all the kodicom video drivers, re-enable them and then start diginet. This is a good old-fashioned hack - I don't know why diginet doesn't think the drivers are available, and I don't know why this works, but it does, and that is good enough for me.

I replaced the Startup menu shortcut to diginet with a shortcut to my batch file so the process will run automatically before starting diginet.


I hope nobody else has to suffer the pain of trying to get Kodicom to recognize its drivers, but in the event you do run into the 'driver not found' issue and want to try this process, follow these steps:
  • 1. Download DevCon and run the self-extracting executable.
  • 2. Copy the devcon.exe from the devcon i386 directory to your c:\diginet directory
  • 3. create the 'diginetgo.bat' file as seen below - place it in your c:\diginet directory.
  • 4. Add a shortcut to your 'start' menu to run 'diginetgo.bat', and remove the shortcut to run 'diginet.exe'

diginetgo.bat
Code:
c:
cd diginet
c:\diginet\devcon disable "PCI\VEN_109E&DEV_036E"

c:\diginet\devcon enable "PCI\VEN_109E&DEV_036E"

c:\diginet\diginet.exe


BTW: The motherboard is an Asus P4S800D-X, and I tried Kodicom drivers V9.0018, 9.0020, and 9.0085. I finally stuck with my original 9.0018 version.
 

iszucs

New Member
I had this issue with Asus motherboards.
But this only happened when I started the pc with no ps/2 keyboard and mouse attached.
With keyboard and mouse, there was no problem.
 

shoebee

New Member
Thanks for the great fix. It works well, however, your code is flawed. The "cd diginet" should read "cd c:\Diginet". So it will look like this:

[codebox]c:
cd c:\Diginet
c:\Diginet\devcon disable "PCI\VEN_109E&DEV_036E"

c:\Diginet\devcon enable "PCI\VEN_109E&DEV_036E"

c:\Diginet\Diginet.exe[/codebox]

Now I can finally use that usb kvm switch ;)
 
Top