"Lost Comm" errors on addt'l keypads


Active Member
I am trying to get my 2nd keypad setup on the ELk but am running into problems with it. I am hooking it up through a DBH and have verified the wiring. I have set the addres on it to 2. When I power up the system the keypad shows the system info and then just shows "Lost Comm.". I tried with a diff keypad and got the same issue. The main keypad works fine. When I unplugged the main one and tried only the 2nd one I still got the error. Any suggestions?
IVB said:
Did you enroll it?
I did try the bus module enrollment from the RP software but it can't find any more than the original keypad. I should have mentioned that since my first thought was enrollment issue.

Other ideas?
Verify your wiring is correct. Sometimes it is wired correctly with a bad connection or you could have the data lines reversed etc.

If possible connect the keypad directly to the panel and try enrolling it. If it works then you know its a wiring issue.

Odds are the hardware is fine.
Did you assign keypad numbers to each of the keypads. The default is 1 and it will only find the first keypad numbered 1.
As Digger said,
Move the second keypad to the control and enroll it. You can use ELK key, 9, (installer code, 172839 is default), right arrow.

After the enrollment process completes, it should indicate all the devices attached to the data bus.

Normally the problem with a device is the Data A and Data B is reversed or not connected properly.

Power the control down and measure the resistance across Data A and Data B at the keypad connector. It should show between 50 to 70 ohms if everything is connected and terminated correctly.
this turned out to be an issue with my DBH. I had two DBHs and on the first one I was only using the first two connectors. The third port connected to the other DBH. When I was trying to hook up the keypad I had it plugged into the 4th port. The problem is that the 2nd DBH had a terminator on it. As soon as I swapped the ports (DBH to 4, keypad to #3) it all worked