M1 Input Expander problem

Steve

Senior Member
Well I was hoping to make a very positive post about how smoothly my M1 installation was, and for the most part it was great. I do have one issue that I ran through tech support but thought I'd ask here too.

My setup *was* Controller bus to input of retrofit hub, Branch A of hub to Input Expander and Branch B to keypad. C & D waiting for touchscreens.

Everything was going gr8 until I decided I wanted all the latest code. Control was already at latest but expander was a rev back. I d/l'd the latest code and went to do firmware update for the input expander. It started and after 2% it came back with error to the effect of upload failed (don't remember exact verbiage). At this point the expander got 'lost'. Now there is no blinking light and the system does not see it. Bus enrollment does not find it and firmware screen says no expander found.

Ok, tech support suggested to eliminate retro hub from equation and direct connect expander and keypad to control. I did and still no go on finding expander. Waiting for call back now but they said next step would be to pull expander and send back to them.

That's the frustrating part! I've reflashed lots of pc's and devices in past, power was never interrupted, cable not pulled, etc. Don't think it was PEBCAK (Problem Exists Between Chair And Keyboard). Is there anything else I can try - really don't want to have to ship module back and wait for them to look at/fix and send back. I'll be without 6 zones during that time. Any suggesstions welcomed!

Other than that so far system is awesome!
 

Spanky

Senior Member
We recently found your problem in an installation.

The version of code in the input expander while updating software responded back to the packet faster than the M1DBHR could turn around the direction of data, hence the first or second byte of the packet was lost.

To reprogram the input expander:

Connect the input expander directly to the M1 so that it is not going through the M1DBHR.

Re-enroll the devices. Make sure the input expander shows up.

Re-program the input expander. Make sure you have the software version that fixes the problem. Send request to: [email protected]

Connect the input expander back to the M1DBHR.

Everything should be cool!
 

Steve

Senior Member
I tried that - see 4th paragraph. Even with the expander and keypad connected directly to the M1 it could not be enrolled. The led also never would blink. Tech support gave me an RA # and the expander was mailed out this afternoon. Looks like something happened to the boot code but I don't think I even touched that.
 
Top