M1 not 'seeing' RCS thermostat


Active Member
I know its a repost of my post in Home Automation, but posting here since its the ELK forum and I have now apparently narrowed the issue down to the ELK side of things.

Latest update :
I decided to purchase a cheapy RS485/RS232 adapter from a friend and tried it out tonight. The RCS software for Thermostat control works great. No issues at all with communication.

The ELK M1XSP however, is not working right. I don't see any noticeable error/flashing messages on the M1XSP. Just about 10 flashes and then a number of quick flashes, in a repeating pattern. From the manual, this appears to be normal behavior.

BUT, I still get nothing on my keypads. When I go into the system and check on thermostats it just shows:
T01 : Not Enabled

This is really frustrating. I have re-enrolled the XSP and flashed its bios as well. I have re-verified all the jumpers on it and still nothing. I swapped out the wire I was using between the XSP and the RCS control unit, nothing. Any ideas? How can I proceed on this? or should I just give up on the ELK controlling it and use CQC for it instead (not what I want to do due to wiring).
Which RCS model do you have, the TR-16 or the TR-40?
Is it the RS-485 or RS232 model (They use to sell both 485 and 232 versions I think but only 485 now) ?

I have the TR-40 RS485 running off an M1XSP so maybe I can help..
I remember I read the Elk instructions wrong when I first did mine. The ID selector switches have white as the button position (which is the color inside the XSP) but I reversed it (so if the white piece was on top, I read it as being on the bottom since that part was dark). Silly mistake, but in case you did the same, you might want to check that.
bmil said:
Which RCS model do you have, the TR-16 or the TR-40?
Is it the RS-485 or RS232 model (They use to sell both 485 and 232 versions I think but only 485 now) ?

I have the TR-40 RS485 running off an M1XSP so maybe I can help..
The one I have is RS485, the TR-40. I may just take a pic of the M1XSP settings to show everyone that I think I am matching the settings the manual requires.

Also, in looking into it more, I may just go with CQC control of it. Looks like CQC can set the display text on the unit while the ELK does not provide that capability. Unless I'm misreading something...
Mike is right. The XSP manual can be confusing with their coloring for the jumpers. It would be nice if that's your problem.. A picture or listing of how ALL your jumpers are set might reveal something.

Also make sure the control unit address is set right, i.e. address 1 if your only Tstat (grasping at straws now). Are your bus terminations set right?

Guess there is always the possibility of a bad XSP. With me, I usually discover something small was causing the problem when faced with something like this that's driving me crazy..

You're right about sending text to the tstat display. You can't currently do it using the XSP. Several of us have expressed our disappointment with this on the Elk board.
well apparently I just needed to take its picture. Its working now, but I have no idea why. This is a bit frustrating, but i guess I'll just not know what happened. I took off the black plastic cover, snapped a couple pics, and put it back on. go inside and double check the keypads and all of a sudden I now have the temp displayed. very odd.

Still may end up with direct connection to the ELK later for text capabilities, but its working for now.
Glad to hear you got it working.

The other sugestion I was going to make was to make sure you enrolled the devices after installing the M1XSP. Use installer menu 1 to enroll the devices.
You may have jiggle a wire when you took the cover off. If it quits again, suspect a loose wire.
Not sure if this thread is still being monitored but I have a similar (although opposite) issue. The Elk M1 is getting temperatures from the RCS thermostats via XSP expander BUT is not able to send any settings to the units. The system was working at one point, then started working sporadically. I contacted Brad at Elk support and he suggested upgrading the firmware. Did that and now NO settings are sent. I have sent pictures of the XSP board settings to Brad for review, thinking that perhaps the firmware upgrade might be less forgiving than previous software for improper jumpers, etc. Just curious to see if anyone else in the field has run into a similar issue or has any ideas on best ways to troubleshoot this...