M1G Keypad trouble

dscline

Active Member
Hello,
I also posted this on the Elk board, but trying here too. I installed my M1G a couple weeks ago. Today I removed the keypad to connect some wires up to the auxiliary input and output zones available on the keypad. The output got connected to a small relay, which will open/close to toggle my t-stat (mounted directly above the keypad) between occupied and unoccupied mode. The input got connected to the wires that WERE running to these inputs on the t-stat. The other end of that wire pair goes to an x-10 relay which formerly activated the occupied/unoccupied mode. This will be re-deployed to another purpose, but I went ahead and connected the wires while I was there.

Upon putting the keypad back in place, and powering up the system, the keypad displays "KP Addr->1 Lost. Comm.". A little whilei later, the voice announces "Keypad module missing". The only wire I disturbed was the black wire, which I temporarily disconnected to be able to join the commons from the relay and spare wire currently going to the x-10 relay. The brown & blue wires weren't previously connected, but now are attached as described above. It does get SOME communication, because on boot-up it correctly displays the control's s/n. None of the buttons do anything, except the Elk button beeps. What would cause this?

Thanks!
 

Digger

Senior Member
Sounds like an open or short on the dataline (white and green wires). You know that the + and - are ok since you have power at the keypad.

Elk set up the keypads to beep if they lose communication with the panel.
 

dscline

Active Member
Thanks. That was my first thought, but if that's the case, how is the keypad getting the s/n from the control?
 

dscline

Active Member
As it turned out, it was a break in the white wire. Between the fact that it worked before, and the fact the keypad was still displaying the s/n of the control, I figured it must have had something (directly) to do with the connections I'd made to the auxilliary zone/output. When I installed the M1, I re-used the existing keypad wiring from the previous installer, and he left NO slack in that wiring. I guess the one last messing around with the wiring caused a weak link to break.

All fixed now. :D
 

Digger

Senior Member
Glad to see it worked...... FYI its pretty hard to damage an M1 or an ELK keypad. Odds are if something happens it something basic.
 
Top