M1G wont arm in away mode


New Member
I've had my M1G system up for about 6 months. I have a serial exp with a UPB module, a CADDX wireless exp, a mix of wireless/wired sensors and motion detectors, about 15 UPB switches, an output exp, and 4 speakers on Output1. I am running the latest firmware on all devices. I am amazed at the high reliability of the system.

But recently, I noticed that whenever I attempt to activate "Arm Away" mode (either via the keypad, keyfob, or ElkRP) the M1 goes thru the exit delay countdown, then arms in "Stay Mode." The keypad indicates "Arm Away" during the entire exit delay, but immediatly switches to "Arm Stay" afterwards. I have repeatedly tested this functionality and cannot figure out a way to arm in "Away Mode."

Have any of you M1 Guru's encountered such a problem, or have any ideas? Am I missing some config parameter somewhere?

Any help appreciated.

I recall something about the modes being "smart". When you arm in away mode, are you then actually opening a door as if you were leaving? If the system doesn't see a door open to indicate that you exited, maybe it is assuming you wanted "stay" mode.

I assume this feature can be turned off, because otherwise you would not be able to arm in "away" mode with a keyfob from outside the premises.
Wayne is correct. If you want to disable this behavior, look in RP under the Area tab, the checkbox labled "Auto Stay Mode after exit time if no violation".
Yes, it certainly sounds like Auto Stay Mode. From the Elk user manual:
Auto Stay Arming
(Optional) If this feature was enabled by your installer, it will automatically
change the arm mode from Away to Stay if you none of the perimeter delayed
doors are opened during the exit delay countdown time.
Secure all protected doors and windows.
1. Enter a User code.
2. The Exit key will light and the exit tone will start.
3. As long as you don’t open or exit through any delayed doors,
Stay light will come on and the Exit light will go off at the end
exit delay time. The system is now armed in the Stay mode.
To enable/disable it go into RP and the Areas page. Go to your Area (like Area1) and on the left side in the Arming Options section the first checkbox will enable or disable this feature (Auto Stay Mode after exit time if no violation).

Edit: I guess Sandpiper types faster than me :blink:
Check your area defintions. There is an option that says:

If Yes, the control will switch from AWAY mode to STAY mode at the end of the exit delay time if no exit zone is violated (no exit detected). NOTE: This tracks the longest of the two exit timers. All interior zones are bypassed in the STAY mode. Default value is No.
Thanks Guys,

You're right. If I violate a zone during exit delay, the system arms "Away." This is not a real problem, except when using the keyfob. I'm debating pro's and con's of the auto stay arming.

The feedback is appreciated......