M1KPAS beeping and quirky


I'm hoping someone can point me at a solution to this before I order a replacement that I may not need.
I have an M1G  system that sprawls over a fairly large area.  The last area has an M1KPAS that is used for access control.  There are 6 keypads in the system daisychained to a final length of about 300ft.  Let's call the keypads A thru F with A being very close to the panel and F being the furthest away.  F is the problem keypad.  Keypad E - works fine and is about 200ft from the main panel.  The run from E to the problem keypad F is roughly 100ft.  I've checked termination and IDs and that all seems fine.  There is one device past the problem keypad and that is an M1XRFEG wireless receiver that is working fine so far as I can tell.
The keypad beeps continuously and doesn't respond properly to keypresses.  It will sometimes accept a keypress but more often than not it won't.  
The wiring to it is not ideal.  The last run is on Cat6 network cable and I've twisted together the colored pairs  (O/W with O, B/W with B etc) to turn this from 8 conductor to 4 conductor in an attempt to minimize voltage drop.  I'm fearful that this may be where my problem lies but this keypad has worked in the past with this configuration.
I added a secondary power supply (Elk P112)  to the daisy chained line about 150ft in to help with voltage drop.
When I run bus module enrolment it finds the keypad in question just fine.
Any thoughts would be appreciated.
I think you are saying that the M1KPAS worked fine for some time, and that now this is a new problem, is that correct? 
Have you measured the voltage at the M1KPAS to see if it is around 12 to 13V? 
You said you added a P112 power supply to help with power.  How did you wire it in?  Is the P112 NEG terminal connected back to the M1 NEG?  Do you have the P112 +12V terminal separated from the +12V coming from the M1 daisy chain?   Did you add the P112 in an attempt to fix the problem, or was it working with the P112 previously? 
You say your termination is ok, but it would help if you described exactly how you have the devices located on the data bus and where you placed the terminators.  We've all made mistakes with termination at one time or another. 
It's ok to twist together 2 pairs of wires for the power, but you don't want to do that with the Data A and Data B signals.  Data A and Data B should use the two wires from one pair (e.g. Org/Wht to Data A and Wht/Org to Data B ).   The data wires do not carry significant current, so there is no need to be concerned about voltage drop on them.  If you double up on the Data pairs, that can cause issues with the signal quality. Note that if you have a M1DBH, you do connect two wires to each data signal, but that is different because you are not placing them in parallel.  The second wire is used to extend the signal on to the next device. 
Before you order a replacement, I would try connecting the M1KPAS directly to the M1 with a short length of cable and see if it works that way.  Remember that the data bus can not have more than two branches, so it may be easiest to disconnect all the other stuff to try this. You may need to temporarily change your termination points when you do this.   If it works that way, that suggests that it may be more of a wiring problem rather than a bad keypad.  
Sorry for all the questions, but more information will help to figure out what to try next. 
OK - finally some time to go through this.
So I'm actually using a DBHR that has 5 runs on it.  There are numerous expanders, keypads, and RF interfaces along the various runs and it's quite the ordeal to sort through all of what's there.
Since most of the runs seem to be trouble free I'm going to focus on the one that has the issue.
That one is the one that has the P412 on it.  I guess I should confirm how I wired that in before anything else.
From my M1 main unit I've run the two data cables and the ground down to the P412.  From there I've joined the M1 ground to the P412 output ground and I carry the P412 positive output on from there to the devices on the chain.  That seems intuitive but I'll start by verifying with you that this is the correct way to do this.  I've confirmed the 12V jumper is set on the P412 
The run in question is one of two home runs on the fourth channel of the DBHR.  I'm going to confirm all my terminations etc. in my next message but for the moment I believe that the problematic run is terminated at the last device, and the other home run on that channel goes straight to a terminated keypad.  Since there are two terminated runs on this channel I've removed the jumper from JP5 on the DBHR
So far so good?
You've left me a little confused... In your earlier post, you said you had a P112 power supply.  In your last post, you said it's a P412, and you set the jumper to 12V.  From the data sheets I have on these, I don't see a 12V jumper on either  one. 
It sounds like you've wired things correctly and have them terminated correctly. 
Just to see if I have this right, I think your troublesome wiring run has a M1KPAS and 2 other devices, and some/all are powered by the P112/412.  Something like this:
Term----M1KPAS--------Other Device------M1DBHR-B4-----Other Device----Term
Sorry - I had forgotten what it was - I installed it years ago.  I was going by the pic on the website.  I went down to look and it's a P624
I'm assuming that what you're drawing there are two home runs coming off branch 4 on the DBHR.  In that case you're mostly right given what I had previously said but in order to facilitate troubleshooting I took the second branch off B4 on the DBHR and moved it to branch 1 that only had one M1KP on it. Since both those keypads are terminated I removed JP2 on the DBHR. Those seem to still work fine.
So at present it looks like this
M1G -> M1DBHRB4 -> M1KPAS (not term) -> M1XRFEG (not term) -> M1KPAS (not term) -> M1KPAS (not term) -> M1KPAS (not term) -> M1XRFEG (terminated)
Since only one branch on B4 is now terminated I've installed the JP5 jumper on the M1DBHR
I only send the two data lines and ground from B4 on the DBHR to the first M1KPAS.  The + power line is not connected.  Between the first M1KPAS and the first M1XRFEG I have the P624 power inject into the + and - lines with the ground shared between the P624 and the ground cable from the M1G
I hope that makes sense now. Sorry - as you can see it's quite a large and spread out system - that's just one run.  So it's taking a bit to identify and document all the parts, device numbers, and terminations. Daisy chains can be pretty confusing to look at - especially in mine where the color coding changed from the first install to the later additions.
Your wiring and termination looks correct.  Checking the current draw numbers for all the devices on the P624, it doesn't look like it is being overloaded.  Still , it would be a good idea to check the voltage at each device to be sure. 
Since you appear to have a large system, have you used the Elk current draw spreadsheet to check that the M1's power supply is not being overloaded? 
Since you have the M1DBHR is the middle of all this, one other thing you could try is exchanging the branches on M1DBHR-B4 with one of the other ports  and see if the problem stays with the M1KPAS that originally had trouble, or if the problem still shows up on port 4 on a different device.  That would help eliminate the M1DBHR as part of the problem. 
I would also try exchanging keypad F with one of the others to see if the problem stays with the  last location, or whether it moves to the new keypad position 
It would also be interesting to connect the problematic M1KPAS directly to the M1 to see if it misbehaves. 
Going from device to device was the only way that this was going to be found.  One of the wires had broken off at the B connector making it intermittent.  The only reason I found it is that I pulled out each and every set of wires to map it and one wire stayed behind.   I've since gone and soldered every junction and put wire nuts on instead
Once that was connected the rest fell into place nicely.  The KPAS that was acting up gave me some grief - it reset and took address 1 which conflicted with a KP in the house when I went to enrol - that took a bit of figuring out but this isn't my first rodeo.  All works smoothly again.
Thanks for being patient with me and suggesting things along the way.
I'm glad you found the problem.  Data bus problems are often tough ones to figure out, especially with many devices and so many connection points.  It makes it difficult to figure out whether it is a bad device, bad power, or bad wiring.  Sometimes, a tiny nick in the wire is all it takes for a wire to break from the slightest movement.  It sounds like that might have been the cause in your case.