M1XEP firmware update


Active Member
Elk has released the firmware update that is supposed to fix the email issue for some people. Has anyone been brave enough to try it yet? :)
Since no one else admitted to being a guinea pig, I went ahead and decided to try it. The upgrade went smoothly, and email is now working! It does, however, still require the IP address of the mail server, as some had suggested. For whatever reason, DNS doesn't seem to work for it.
How do you find the IP address for a mail server? I have Comcast and haven't been able to get the IP address.
On a Windows XP machine open a command prompt window (start->all programs->accessories->command prompt). Ping the mail server using the server and domain name (i.e. ping smtp.isp.net). The respone to the ping command will include the IP address.
Yes, and with Comcast, you DON'T need the username and password entered. I wish they'd get the DNS issue fixed... I don't like the idea that that notification of an alarm is partially dependent on Comcast's email server's IP address not changing. <_<
We have noticed if you set the M1XEP for DHCP sometimes it gets the DNS address, sometimes it does not. ELK is investigating to see if it is the M1XEP's problem or the DHCP server's problem.

In the meantime there are two work arounds:
1. Set the M1XEP to a static address and enter the DNS address manually.
2. Determine the SMTP servers IP address (numeric) and enter it instead of a URL.
Spanky said:
1. Set the M1XEP to a static address and enter the DNS address manually.
I will try this, thanks. Currently, the M1XEP is set to use DHCP to get its address, though I do have a static address set for it in my router. I did briefly use static when I was playing around with initial set-up, but that was before I even tried email. I did notice that when clicking the option to use static, the fields appeard to be filled in with the correct info that it got via DHCP, but I will check to see if "forcing" the DNS helps.

Thanks again.