M1XEP went away

BradScott

Member
After upgrading to ElkRP 1.6.16, I had problems linking to my M1G, but finally got that to work through the serial cable. So, I upgrade the M1G firmware to 4.4.10, and everything seemed good. But, I needed to make changes the the M1XEP setup (to change how it handles email), and when I sent the changes, it said the M1XEP would need to disconnect to get the changes. Once it disconnected, I cannot get it to reconnect.

I see a few lights blink (brown and green on the Rj45 jack), so it appears it is trying to get to the DHCP server (I also tried rebooting my router / DHCP server). Regardless, I cannot find my M1XEP using the Find command under the M1XEP setup. And, my router is not showing a connection to the M1XEP -- so clearly the problem is no connection to the router. This worked well until I upgraded ElkRp to 1.6.16, so either something changed when I did my upgrades, or I screwed something else up.

I have tried forcing the M1XEP to a static address, but no response from Firefox on address 192.168.0.251.

I cannot connect to the M1G through a serial cable unless I chain my UPB controller cable and the serial cable that connects to the M1XEP, so I cannot look at the M1G that way, and my dial-in is not answering.

Anyone have any ideas? Obviously, I can get a longer serial cable to hook up that way, but then what do I look for?

thanks!
 
Just to make sure I understand correctly, if you punch in the IP address for your router and click on the DHCP client list, there is no listing for the MAC address from the M1XEP?

My M1XEP has a solid yellow/orange light with a valid connection to the router.
 
CORT said:
Just to make sure I understand correctly, if you punch in the IP address for your router and click on the DHCP client list, there is no listing for the MAC address from the M1XEP?
Well, I'm confused by that list. It showed the M1XEP mac address, so I disconnected the cable, and it still showed it for several minutes. So, I restarted the router, and now it doesn't show it, but it also doesn't show my desktop computer, and I have full internet access. So, I question how valid that list is. I'm wondering if the address from before the reboot was the address it used on Friday night when successful.

So when I try to FIND the M1XEP, I still find nothing.
 
Ok, it sounds like the M1XEP might be associating with the router under a different IP address than what you expect.

Plug the M1XEP back into your router, restart the router, then look to see what IP address is associated with the mac address of the M1XEP. Hopefully the mac address is there with a valid IP address. Note this IP address and then try entering it in the url line of your broswer window. This should pull up the Elk M1 virtual keypad (so far not compatible with Internet Explorer 7).

Another thought is that your router is seeing the Elk M1XEP mac and assigning it the last IP address that was leased to it, but the M1XEP may now be in static mode not looking for an IP address. You might see if you can purge the M1XEP mac from your router and recycle things to let the router associate it with a new IP address.

By the way, what router are you using? Good luck.
 
My router is a Belkin 54g. I don't see anything listed under DHCP clients except my Tivo and my main computer now.

I had tried putting a jumper on jp2 to force it to the address 192.168.0.251, but, I still couldn't find the M1XEP (in Firefox). So I removed the jumper, and it appears to be trying to get to a DHCP router (based on the lights).

I can connect to the M1G directly with a serial cable just fine, but, until my new serial cable arrives tomorrow, I have to pull the one off the M1XEP so I can chain it to reach the desktop computer.
 
Okay, I interpreted the directions a little bit differently today, and so I removed the Jp2 jumper while the M1XEP was on. This allowed it to assign an IP address, as viewed by my router DHCP client list (192.168.2.3). That's the good news. The bad news is that ElkRP still doesn't find the device, and when I type the IP adress into Firefox, it times out without a response.

My orange and green lights on the M1XEP RJ45 connector are now steady on.

What should I try next?
 
is your computer still set to an IP of 192.168.0.XXX? if so, you need to assign it a static of 192.168.2.XXX to talk to the ELK, then you can set the correct IP on your ELK, and reset the static on your computer to DHCP
 
I tried pinging 192.168.2.3 again, just in case – and one out of the 4 attempts did get a response. bytes=32 time=2ms TTL=60

I tried again and 4 timeouts. Again and 3 successes (time=2ms; time=<1ms; time=1ms), then the 4th failed. Tried again and all four timed out. Tried again and one of 4 worked.

I’m clueless on why it works sometimes and not others, but it does. I even tried hooking a cable up straight from the router to the XEP in case the wall wiring was bad, and the results were the same. Almost all timeouts, but one response to the pinging.

Any thoughts on what I can try?
 
I can buy a crossover cable and try that -- eliminates the router. But, how will the M1XEP know to listen? Or do I have it set to a fixed IP address?

thanks.
 
In RP use the find feature and you should see the M1XEP. If its directly connected it should see it right away.

If you still have problems I would call ELK Tech Support.
 
Got my crossover cable, set my local IP address to 192.168.0.2, and tried pinging 192.168.0.251 -- same results Occasionally a successful response, but most timeouts. I did see a response I've never seen before -- hardware error.

So, the M1XEP was behaving the same as when connected to the router. I would get an occasional response (3 out of 4 once), mostly 0, occiasionally 1. But, never found in ElkRP.

Any other ideas on what to try?
 
I did call support, and I'll have to return it. At least I now know there is nothing I can do locally, and I have a solution planned.

Thanks.
 
Back
Top